WMP cannot see Connect

OK, I’ve read through the forum and tried as many fixes as I can find. I checked that I have the firmware update, I have WMP 11, I’ve done the force quit (hold the button for 10 seconds) I’ve checked the Device manager in Windows XP and there was a conflict (MTP device) but the reset fixed that. The Connect is recognized with WMP on my work computer (also XP).  I’ve tried to use the Sansa Connect disk for a driver but there does not seem to be one on there.

What am I missing?


  I was having the same problem. Try holding the On/Off button down for 30 seconds. It will “reset” the player without losing any of your loaded content. Worked for me, hope it helps you out.

Is anyone else still having this problem? I’m running Vista and WMP 11 does not recognize my Sansa Connect. I’ve reset default factory settings once and it worked. Next time, it didn’t. Does holding the on/off button down for 30 seconds do something different than resetting defaults?

By the way, Jukebox had a difficult time consistently finding Sansa Connect. Also, when I try to open the Sansa Connect device through my computer, it locks everything up. Is it Vista to SC?


Run the Sansa Connect Recovery Tool


Common issue with Vista Borking the communication with the player, Had to recover mine 3 times to make it stop…after that tho I have had no issues.