Sansa won't connect or be recognized on my computer

I just connected my Sansa to my computer and uploaded all music I wanted into the player.  I used my Windows media player.   I have Yahoo jukebox already but I don’t upload any music to my mp3 players that way, I only use the Windows media player.

Now, my Sansa connect is not recognized in any way, shape, or form thru the Windows Media player or the Yahoo Jukebox.   I have another Sansa mp3 player that is recognized on both players.

Why did it allow me to upload the first time without any problems but now I can’t edit the player in any way?

Doesn’t come up on other computers in the house as well.

Any suggestions or ideas?


Message Edited by bee1325 on 12-27-2007 08:28 AM

I suggest the following:

  1. There is an issue with Windows seeing the Connect after it has been put in sleep mode.  Try shutting down the Connect (hold down power button for 8 seconds or longer), then reboot.  If it doesn’t show up …

  2. Verify you have the latest version of Windows Media Player 11.  Early versions had a buggy MTP driver which is used to communicate with the Connect.   Go to the main menu and click Help>Check for Updates.

  3. Apply the WMP hotfix related to MTP recognition issues by following this link:

The original shipped Connect firmware had this problem. You can temporarily work around the problem with full restart of the Connect (hold power button 8-10 seconds to turn off). Our latest firmware will not have the problem at all. The firmware will update automatically while you listen to Internet Radio, or you can run the recovery tool. Please refer to theFAQs for more details.

Below are the links to the resources and applications useful to Sansa Connect owners.

The new User Manual, FAQs and utilities are posted at

If rebooting the device doesn’t allow recognition with your computer, try resetting the unit.  Just hold the power button for 15-20 seconds, and then release.  The device will go through its booting process and when that is finished, try connecting to your PC again.  Don’t worry, the reset process will not erase anything from your device. 

I hope this helps


oh…sleep mode vs shutting down…now I get it…I wondered why the battery had run out completely when I had it off all night, so I thought :)  After getting the connect to shut down completely like suggested, my player shows up in windows media…I will bookmark this page in case I have further problems…thanks a bunch!!!

If you don’t have latest firmware, the problem will recur. If you have the latest, you shouldn’t have the problem again.

Also, you will get all the new features with the new firmware.

The current firmware is ZAP:

Reference the FAQs for details to update the firmware.

Went through all three options and the the mp3 player still isn’t recognised

Not much else. Maybe try a better USB port, like if you’re using a desktop, the rear ports get more power.  And in Device Manager, check that you have no yellow exclamation points for the device/drive.

Does your computer recognize something, but not anything useful to read or write to the Connect?  Or just nothing at all?

Greig wrote:

The firmware will update automatically while you listen to Internet Radio

Actually, has anyone confirmed that lately?  Because I’m pretty sure the firmware has been removed from the Zing servers.  Unless the (installed) firmware has some failover capability to another server to download the firmware, it might be that the Recovery Tool is the only way to update the firmware, now.

I have a similar problem; while my Sansa device will charge on my computer and my computer does recognize that it exists, when I try to get into any of the folders they come up empty. In addition, I cannot transfer any files to my Sansa device; when I try from Windows Media Player or Overdrive Media Console, neither of them recognize that a device is connected.

I have tried: rebooting (holding the power button while it is connected to turn it off, then doing the same thing to turn it on)

                  looking to update the driver (is updated)

                  looking to update Windows Media Player (is version 11.0.6002.18111)

That’s strange that your computer recognizes that your Connect exists, but WMP doesn’t.  If you run My Computer and select “Details” off the “View” menu, how does it describe your Connect?

Also, when you double-click on your Connect in My Computer, what folders does it show, and what folders under that?

@capriciousreboo wrote:


I have tried: rebooting (holding the power button while it is connected to turn it off,

Sorry, but I have to ask, because your way of rebooting is not the same as has been suggested earlier in this thread by music_legend and GnisiBrianJ25us, namely, that you need to hold down the power button for at least 8 seconds (until the display changes from “Sleep” to “Shutdown”, or some words like that); then starting it up again (push the power button) and waiting through the 5 balls.  Then try reconnecting your Connect.

Sometimes Windows weakly recognizes the Connect, and this full shutdown/startup often cures this problem.