Windows not recognizing Fuze:what could've happened?

Hi all:

My Windows isn’t recognizing the Fuze. Yesterday, when I plugged it in, it worked great and I updated the firmware then copied my music and podcasts.Unplugged it, then the Fuze updated the firmware. I listened to some podcast. Today I wanted to add some new stuff but when I do, Windows suddenly doesn’t recognize Fuze. The Autorun box pops up but the inside is blank. When I take a look through Win explorer, the Fuze is there but when I click on Int memory and then click on the Music directory, the music doesn’t show up.

I read through lukas101’s thread. So I changed my USB detection to MTP, did a soft resent then did a rebooted the computer but the same problem persists.

I took a look at the Device manager but I see a new entry called Portable Device then Sansa Fuze. So I deactivated it it then unplugged and then replugged the Fuze; nothing happened. So I reactivated the Fuze driver.

I’m still at a loss as to what could’ve happened. So a few questions

  1. Should I change the USB connection to AUTODETECT?

  2. In Windows Device manager should I deinstall the driver and then force Windows to reinstall it after I reboot the computer and then replugh the Fuze?

3)  Any other ideas or tips?



“When I take a look through Win explorer, the Fuze is there but when I click on Int memory and then click on the Music directory, the music doesn’t show up”

That means you changed the USB mode from what you had when you transferred the files.  what makes you think the player is not recognized?

Message Edited by JK98 on 12-28-2008 02:33 AM

I am confused. What was the USB mode set at yesterday? What was it set at today when you didn’t see the files you transferred yesterday?

When it says internal memory, I guess this means you are connected in MTP mode(or AUTO defaulting to MTP). MTP is a virtual device, so it will be handled differently by the device manager than MSC which treats the player as a physical device.

Message Edited by JK98 on 12-28-2008 02:43 AM


Sorry. I’m shortening too much information:

  1. yesterday (27 Dec) Fuze was on Auto Detect It worked fine and I was able to install the firm update and copy the various podcasts and music

  2. Today, I still had it on autodtect when Windows didn’t recognize it. By nonrecognition,I mean that Windows doesn’t assign it a drive letter (it’s E:)  and the dialogue box for the autorun is blank. I see a small Fuze icon on the taskbar but when I double click it I just get that blank autorun dialogue bo

  3. After I read lukas101’s thread, I then change Fuze’s USB mode to MTP and did everything I described. Windows still didn’t recognize the Fuze

If I go to Win explorer I see the Sansa Fuse. I double click the IntMemory and I see the various directories. I clicked on the podcasts subdirectory and I saw nothing even though there are the podcasts. I was still in MTP mode.

  1. I’ve seen put it back auto detect and I then plugged into my wife’s MAc and I can see all of my podcasts and music.

  2. I cleaned out my temp files and did a quick defrag of the computer hard drive in case there’s anything that’s interfering with the recognition. I rebooted the computer, plugged in the Fuze (in Auto detect mode) and I still don’t get a drive letter assigned to Win explorer.

So any suggestions as to what else I can do?




Sorry I just remembered something: Yesterday, before removing the Fuze , I didn’t unplug it. Instead, I went to the taskbar and right click the REMOVE PERIPHERALS icon and then clicked on the E:\ drive. I then got the bubble informing me I could safely remove the peripheral (i.e. the Fuze) So I’m wondering if I deactivated something within Windows that recognizes the Fuse. If so, how can I restore the function?

Thanks again!



Sorry but I solved it. I switched the USB mode to MSC and Windows finally recognized it. I’ll switch back to autodetect and see if Windows can recognize it with that option.  If not, I’ll switch back to MSC

Thanks so much for your help! :slight_smile:


In MSC mode, youy Fuze will show up under Devices With Removable Storage and be assigned a drive letter, such as E: or F: and a separate letter for the external memory card slot whether you have a card inserted or not, such as F: or G:

In MTP mode, your Fuze will show up under Other and you’ll see the ‘Internal Memory’ icon.

Files put on in one mode are not visible on the computer while the player is connected in the other mode.

The AUTO setting connects in MTP whenever possible. If it can’t for some reason establish a connection in this mode, then it will revert to MSC which is easier. It’s best to select whichever you find more beneficial yourself, rather than depending on the AUTO setting.


Thanks. I’m sticking with MSC. It works and I’m curious as to why Windows can’t recognize the Fuze when it’s either in Autodetect or MTP. One last question: when I need to update the firmware, will Fuze automatically switch to MTP mode or dop I need to do it manually?

Thanks again!


MSC mode is easier because your computer sees the device as just another flash storage device, like a benign memory stick or something. With MTP mode, now it sees it as a music (or media) device that must be ‘managed’ so there are drivers and such that come into play along with Microsoft’s flawed Media Player. Yes, if it weren’t for MS and WMP there would be no MTP mode at all.

You can update the Fuze’s firmware in either mode, but always check the setting after it completes updating because it might switch the setting back to MTP or AUTO (which is more or less the same thing). :wink:

Thanks  Tapeworm!


My computer recently crashed and after reinstalling windows xp pro, my fuze wasn’t being recognized.  I tried everything listed here and finally got it to see the fuze in mtp mode.  But lo and behold my files were not accessible as there must have been in msc mode.  I finally updated my Windows media player from 9 to 11 and voila, everything was back to normal.  Hope this may help others with the same problem.