The computer doesn't recognize it.

Hello, i was wondering if anyone else has had this problem, and if so, how it was fixed.  my fuze has worked fine on my computer since i got it.   but today, i plugged it in, and the fuze recognized that it was in the computer, and had the “connected” screen, but nothing on my computer.  there was no sign that it was even connected.  i checked on my media player, and on “my computer”  and nothing.  so is there a way to make it recognize the player again?

oh yeah, and i tried a USB flash drive just to make sure that that drive was working, and it picked that up no problem.  so the drive works.  

if anyone could help, i would be eternally grateful!!! 

Thank you!

oh yeah, and i’m running on media 10 if that makes any difference.

Message Edited by kathyhalofan on 08-30-2008 07:41 PM

Hello Everybody, Hello Kathy

We bought our Sansa in the US two days ago and back in France we are having exactly the same problem you are describing, the Sansa Device just does not appear under My computer when it is connected and all our other devices work well on our computer, so it’s impossible to use it ! This is really frustrating. if anyone can help quickly !

Thank you !


We’ve just solved our problem thanks to Sansa Guru 's Advice on this forum . You must switch the USB mode on MSC in the Settings Menu of you Sansa.

Hope this will help.

The Sansa has two USB communications modes, MSC (mass storage class) where it appears as a flash drive, and MTP (media transfer protocol) where it appears as a media player capable of DRM transfers.

To switch modes, this is available via Settings > System Settings > USB Mode > auto/mtp/msc.

If your Fuze is not communicating in MTP mode, or if you have Windows Media Player 10/11, and the device has “always connected fine” without having touched the mode, the problem may be with the MTP protocol, as it’s fragile.  The Fuze is shipped in Auto Detect Mode, and the sample songs were loaded in MTP mode.

Here’s a footnote best noted before going further: Microsoft engineered MTP to look and feel like the basic MSC mode, but it does many things in the background.  Probably the most significant difference between the modes is that files transferred in one mode are not visible while in the alternate mode, when vieed from the computer.  The Sansa will display all files transferred, regardless of transfer mode used.  The most common dilemma encountered here is “where did all my music go!”  It’s still on the device, just not visible until you are in the same mode as it was transferred in.

This problem gets compounded a bit by a quirk in the Fuze’s processor.  If it is busy trying to establish a communications session, the device can get distracted from its other duties.  The biggest one is survival: charging is handled by the processor.  A glance at the Fuze’s display will show you if charging is in operation, by the wee lightning bolt and rolling battery icon.  This is not a fault in the device, it’s a safety issue.  Managing the battery is important, and if the processor is busy, the high charge rate is defaulted off.

In cases where the Fuze simply “disappears” from your computer, on a USB port you regularly use, first check if anything has been changed.  Are there any new devices plugged in that will interfere with the pecking order.  USB ports are great for rapid diagnosis, as you can simply try another one, or unplug other devices to see if there is a change.

You can establish an MSC connection by selecting MSC and plugging in again.  This allows you to check the port, the cable, and in cases of a hungry Sansa, a bit of juice is important.  If you have discharged the device to the lower threshold, communications issues are possible.  Sometimes, a short charging session will bring it up to speed, and you can then try MTP / Auto mode again.

When the device is communicating, go to Computer / My Computer and look for the Sansa.  If the device is listed in the device tree, the currently selected mode is most likely OK.  Go to the Device Manager if it isn’t shown, and look for the wee yellow triangle of doom.

If the warning triangle is showing, simply uninstall the device (don’t worry, Windows will try over again, you won’t hurt anything), unplug, and try again.  I prefer to reboot the PC after uninstalling, as starting from scratch is often best.

If you are still having troubles with MTP mode, don’t worry, the issue is quite common, and there are plenty of suggestions available by entering “MTP Mode” in the search box above. ( I’d like to keep this post short.)

Bob  :smileyvery-happy:

Raph and Bob, Thank you both so much for your help, i did figure it out, it did work in the msc mode i think.  But again, thank you so much! i would have had a heartattack if not for you guys!!! i was so scared!!!  haha.