Computer doesn`t recognize sansa fuze

I have my sansa fuze for over an year and no problem,  but now I`m trying to plug it (in order to add songs) but it turns off and the computer does not recognize it. I have formated it , but again, nothing happened.

What`s happening?

Im sure its not the computer because it recognizes other gadgets and memories, pendrives, external disks etc.

Please help! I`need to have some archives in my fuze again!!!

thanks. 

Have you tried a different cable?

that`s it, solved

thanks!

:laughing:

the user manual states in 3.1.1 step4

“your player will appear under My Computer as a
Portable Media Player.”

no it does not.

downloaded 3 available files using sansa updater

installed, but no app is listed in control panel installed software or file mangler

wtf

some moron puts files in

documents and settings/user/application data/sandisk/sansa updater/downloads

then run the exe to unpack

where is this in your user manual

piss poor install

I guess thats why EVERYONE I KNOW bought the apple

Technically, you don’t have to install anything. If you’re talking about the updater, you don’t need it. It will only install a useless media converter, a manual, and will check for firmware update (there won’t be any for the Fuze+). If your talking about the mini CD it comes with, you don’t need that either. If you’re looking for a driver, you don’t need one. The device should connect to any computer without hassle.

However, nothing is glitch free (contrary to what any iSheep will tell you). However, most issues related connecting the device to your computer can be solved by going into Settings > USB, and switch to anything other than Auto Defect. Most in this site would recommend MSC, as it’s the simplest and most universally supported mode available. MTP is really only needed to transfer DRM-crippled files (although it can make life simpler when recopying modified files to the device, as the device doesn’t recognize changed files in MSC mode).

Also, if you use MTP mode, make sure you’ve updated Windows Media Player to version 10 or higher (not necessary for MSC).