Windows encountered and error while trying to install your software



The Cruzer works on my other computers. And all my other thumb drives still work fine on computer in question.

But when the Cruzer is plugged in I recived the following error.

 " Device driver software was not successfully installed"

In Device Manager I have tried manually and automatically installing drivers.  This just turns up the following error:

“Windows encountered a problem installing the driver software for your device”

“This operation requires an interactive windows station”

I have searched for others with similar problem and tried all bios configs.

Need help


Have you tried this:

When I lanuch the U3 Launchpad Installer I get the following.

"The currently connected U3 smart drive is not a SanDisk compatible device. This installer only works with SanDisk compatible U3 smart drives.

My computer does not see the drive so installing somthing to it is futile.

No Joy.


Anyone have any ideas?  This is still not resolved!


Obviously it’s a newer device in which case not U3 compatible.  SanDisk stopped manufacturing U3 devices several years ago.  If security is your concern try the new security app SecureAccess. 

And if that’s not the problem, I suggest you return the device to the store and get a new one. :wink:

Wow! Ed_P

I hope others read this. It’s like living in la la land.

Obviously, Ed_P I told you what divice it was and you Obviously recomended the U3.

Obviously looking back on our recent post, it was Obvious that secruity had noting to do with my problem.

Obviously it was that my computer does not install the drive.

Obviously the drive works on other computers as obviously stated in previous posts.

So Obviously even if I return the drive to the store, It will obviously still NOT work on the computer I need it to.


I think?


You are absolutely right Jon.  The drivers for the USB device are Windows drivers not Sandisk drivers.  So you should post your situation on a Windows, or Microsoft, website to see if someone there has an answer to your Windows problem.

Let us know the solution that works for you.



Just a follow up.

If anyone else had this problem. I solved it by unistalling my ATI Catlyst Control Center. Installing the Cruzer USB drivers and then reinstalling my ATI drivers for my video card. Don’t have a clue what the conflict was but this solved the problem.



:dizzy_face: Wow!!  Thanks for the update jrinkus.