Why does SMC takes forever to convert and transfer video?

I just got my son an e280 player for Christmas.  We updated the firmware using Sansa Updater, and set the player’s USB setting as a MSC device.  And from everything I’ve read so far, it appears that the only way to transfer videos onto the player is to use the Sansa Media Converter software.

I’m sorry, but the SMC is major crapware!  It works for transferring pictures, but for transferring video, it is a big pain in the rear, and does not work, period!  Unless you’re transferring small video files, say less than 50MB, the program hangs or just crashes, especially while performing other tasks during a conversion, such as browsing the web.  Also, there’s no option to convert offline, meaning doing conversion without having the player plugged in.  Worse of all, it is agonizingly slow!!!

Now, I don’t have the fastest PC in the world, but mine is no slouch either.  I’m running an AMD Athlon 64 Processor at 3700 MHz with 2.5GB of RAM under Windows XP Pro, Service Pack 3.  The movie files are AVIs or MP4 previously converted over from store-bought DVDs.  What I can’t understand is why it takes 4+ hours to convert an approximate 400MB of AVI or MP4 file with the SMC; and that only gets it to 25% - after 4 hours!?  I’ve tried using other software such as Format Factory to convert to MOV file formats (which takes only 30 minutes), then copy directly to the e280’s Video folder, or using AVSMobile Uploader to transfer a MOV file directly, but the player won’t play the video.  It just says - You must use the Sansa Media Converer, or something to that effect.  Am I doing something wrong?  Is there a workaround solution/alternative to the SMC?  If not, does, or will, Sansa plan to improve the SMC software so that it actually works.

I own a Sansa View 16GB player, and am able to play MP4 full-length movies on it with no problem.  But I use Format Factory to first convert my AVI files to MP4 files, which takes only 30 to 40 minutes (and that was for the two and a half hour long ‘The Dark Knight’).  Then I just copy the movie file over to the Sansa View and watch it with no problems (except if I store videos on the expansion card, it inevitably duplicates file names!  Another weird glitch no doubt).

To Sansa’s credit, it does have a great little player (and I love my Sansa View).  Now if only they can make the video conversion process a little less painful process, it would be perfect.

So my dilemma is: Should I ebay the e280, and pony up the extra cash for a Sansa View (or maybe God forbid, buy an IPod)?  Or will Sansa fix the deplorable SMC software? 

If you don’t like SMC, use Rhapsody instead, which sometimes has better performance.

Thanks for the tip, but isn’t Rhapsody a monthly paid subscription service?  Or can I download and use their software for free?  I feel that since I’ve paid good money to buy a MP3 player, it and the software that it comes with should work as advertised without jumping through all sorts of hoops.  Otherwise, it’s like buying a car, but I would need to buy my own tires in order for it to be driven…the music and video content is the gas which I would/could provide myself, but the car should really come with tires, wouldn’t you think?

As far as I can tell, I’m not the only person that is having this difficulty with getting the SMC software to work.  And the problem is not exclusive to the e200 series, but to other players as well, such as the View and the Fuze.  I realize that the e280 is an older generation player for SanDisk, but the company really owes it to its customers to provide a conversion software that really works (even for a legacy player, especially since it’s only one generation ago).  Otherwise they should just advertise and sell the player as strictly a MP3 music player.  At the least they should upgrade the e280’s firmware to permit the use of other conversion software that’s out there as a suitable workaround, which I was able to do with my Sansa View and a conversion software from Format Factory.  What’s more, I not sure that SanDisk has worked out all the bugs in the e280 firmware in so far as its system is concerned, since last night the little unit froze and stop working for no good reason - didn’t do anything different than just plugging in the usb to transfer music.  We’ve tried resetting the system, but now Windows XP keeps trying and fail to reload the MTP device.  I bought the player for my son so he can play music and video, not for me to work as a part-time Sansa troubleshooter/engineer!  I’m at the point of seriously considering returning the unit and get something else, that works!