White screen

I’ve had this fuze 8gb since 11/08. I went to charge it and all I have now is a White screen. I have tried to reboot it and no luck. Also, I  did update the firmware awhile ago and I tried to do it again with the White screen. No help there. Is there anyone that can help. Thanks, Heather 

Try a soft reset first, holding the power switch up in the ON position for 20 seconds, then try powering up again.

If unsuccessful, contact Support at 1-866-SanDisk for further assistance.

In either case, please let us know of your findings here.

Bob  :smileyvery-happy:

Sorry that’s what I meant when I said I rebooted the fuze. Still no luck! Is there a hard way to reset the fuze through the computer?

From the PC, you can format the device, but that will erase all data (music, photos, video, books) from the data area of the device.  Formatting can sometimes work wonders.

The firmware will not be affected by formatting the Fuze, as this is stored in a reserved partition in memory.

Be sure to hold that wee switch up for the full 20 seconds.  You will be rewarded with a divet on your finger too.

You can try reinstalling the firmware on your device, following the directions in the firmware thread.  This may help.

Bob  :stuck_out_tongue:

Well Bob, the divet is there again but no luck. As far formatting through the PC I’ll need directions. I’m a bit challenged in this department but I’m not completely inept.

Hey Bob, I haven’t heard back on the white screen/reformatting through the PC . Should I just get a hold of sansa with this problem? Luckily I haven’t downloaded any music or any information onto my fuze.Thanks, Heather

Sorry for the delay.  If you connect your Sansa, let’s see how it feels like communicating today.

Open a Windows Explorer window by pressing [Windows Key] + E, or via My Computer.  If the device is in MTP mode, it will show up under other at the bottom of the list.  Right click on the Fuze icon, and select properties.  As a handy test device, I’ve just plugged in a Sansa Clip; in the center of the properties box, it shows the firmware version as v01.01.32A.

Make a note of the Fuze’s installed firmware version in this same way.  This is important for installation of the Fuze firmware binary file if needed.

As a note on this bin file: the Sansa Updater is NOT designed to repair the existing firmware build, it is designed to update a lower version to the current one.  If the current version is the same, the Updater assumes all is well and happy.  I’d love to change that, adding a “reinstall current version” box, as this would help a considerable percentage of users.

Now for a format trial, in hopes that we can get the main menu back on your Fuze.

Back in a moment…

Okay, with the Windows Explorer box still open, you’ll see The Fuze icon.  Double click on it, or right click and select either Explore or Open.  You’ll now see the Format option.  Go ahead and format your device from Windows.  Unplug afterwards, and try restarting the machine.  Let me know if you get the happy main menu.

If you are in MSC mode, the device will show up as a flash drive under “devices with removable storage”.  The first Fuze listed alphabetically will be the internal memory.  There’s a file in there, version. sdk. Accessible via Notepad, it shows the following on the wee Clip:


Product: Clip
FW: V01.01.32A
Region: Americas

Note, this is just to see the installed firmware version.  Do not modify this file, as it is critical for normal operation.

In MSC mode, you can right click on teh device and select Format.  BE SURE that the “Quick Format” box is NOT checked.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-03-2009 12:43 PM

Bob, The version is 1.02.26A on my fuze 8gb. Heather

Okay, try formatting, and let me know what happens. 

Bob  :wink:

How do I format through my PC? Heather

See in the message above, how you can navigate to the Format option?  Go ahead and select that choice, and follow the path on the screen.  Are you in MTP mode, meaning you see “Internal Memory” displayed?

Formatting in MTP is a bit different, as it defaults the format settings, but it should work the same.

Bob  :smileyvery-happy:

Bob, I went to my computer and rt clicked on fuze icon, hit explorer. then it came up with Folders and the only thing I could fine was the fuze icon and internal memory which it gave me my music etc folders. Some how I am failing in your directions. I’m not sure if it matters that I have windows xp. This may sound stupid but what is MSC mode? Heather

MSC mode, or Mass Storage Class, is where the Sansa is accessed as a flash drive just like a basic memory stick.  Seems fitting that SanDisk provides a simple way to access the device like that, as it provides compatibility with most any computer, regardless of operating system.

Since you’re connected in the default MTP mode (in this mode, a virtual mode controlled through Windows Media Player), you can right click on the Internal Memory icon and then select Format from there.

If unsuccessful, we can try the other mode.

Bob  :smileyvery-happy:

Ok Bob, now that I feel like dork!:dizzy_face:I see you left me another message concerning the internal memory mode. I now see the format and have reformatted the fuze. I was hoping that this would help but I started the fuze again and again white screen. I appreciate all your time and effort but all seems lost and now it’s sansa’s turn to replace my device. Again you have been patien t and kind and again I thank you!!! Heather

No worries, help is available from Support at 1-866-SanDisk, they can even walk you through the process.  It is my hope here that we can pinpoint the trouble, saving you the time and effort to send the device in for replacement.

Take a moment to register your new Sansa via the SanDisk logo in the upper left of this forum, then go to Support, then the Register box.  All correspondence following, or before calling the Support line, can be referenced from right there.  When it is decided to send you a new unit, the process is convenient:

If your Sansa has problems, necessitating replacement, there’s a one year warranty.  SanDisk will send you a Return Merchandise Authorization label.  In your e-Box, there will be a link to the label, or thay can send it to your regular e-mail account.  The e-Box is better, as there’s a “trail” of steps, and the messages don’t get lost in the usual email clutter.

All you need do is click on the sent link, and print the UPS label.  Then, box up and drop off the Sansa at any UPS Store, or they can pick up at your door too (you’ll need to call UPS).  SanDisk pays the shipping for you.

Bob  :smileyvery-happy:

Bob, Do you think that there was something we missed or I didn’t follow through on something? I can’t see them me giving anymore help then you did. Heather

There’s only one more step to try.  Download a new copy of the 01.02.26 firmware from the firmware thread, following the manual installation instructions.

You can install the firmware in MTP mode, as long as you double click on the Internal Memory icon to open the root directory.  The bin file is dropped along side the folders, but NOT inside any of them.  This is the root directory.

Once done, unplug the Fuze, and see if the screen resumes.

You can try performing a soft reset one last time following the update.

You’ve been patient, and thanks for trying to dig a bit deeper into the white screen issue.  The only times I’ve managed to “get” a white screen, the soft reset has worked fine.

Bob  :stuck_out_tongue:

Bob, Can you walk me through finding MSC mode. Not sure how to get there and how to proceed. Thanks again, Heather


Start with the Fuze OFF.  Slide the power switch down to the HOLD / LOCK position (orange showing).

Now hold the center button depressed while connecting your Fuze to the USB port.  It will connect in MSC mode.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-03-2009 04:30 PM

Well Bob, I did as you instructed to put the fuze into MSC mode and it worked but I can’t download the firmware because it is already on my fuze. Soooo what to do now?:womansad: Heather