White Screen

My sons player has a blank white screen, and nothing will work. I have tried pushing every button and in different combinations to get it to do something, but nothing. i connected it to my computer and it will not recognize it. I do not know what happened to it just before this happened. Any one know what I can do to get it to work?

First, try a soft reset by sliding the power switch to the ON position, holding it there for 20 seconds, and release.

Then try restarting your Fuze.

µsansa

Thank you! It is working now. I still don’t know what happend. Also on the info screen it shows over 200 songs, but he only has 22 songs on it, and it will pop up when we try to load more songs that there is no more space to add songs to.

Just now my Sansa Fuze has also started showing a white screen. I tried the soft reset instrucctions to no avail. Further advice please. TIA.

Try formatting the Fuze, but BEFORE you do that, back up all the files on the Fuze, then try formatting it.

Would that be with the Windows format utility? Quick or Full? FAT32? Thanks.

Settings>system settings>format.  On the Fuze.

Can’t format on the Fuse as the screen is just a white square. Any ideas?

Sorry for the delay!  It’s irritating to watch the video of a blizzard…or is it fog?

Go ahead and format from Windows if desired, with the caveat that it is erasing your media from the device.  You’ll need to reload.  Don’t use the “quick format”, use the basic “full” command, with FAT32 as the filesystem.

Bob  :smileyvery-happy:

OK - backed up and formatted from Windows (full not quick, FAT32), soft reset, flashed with latest firmware. Still seeing a white square. Any further ideas? Thanks.

It could be a bad firmware install, try reinstalling the firmware. If you haven’t already updated your Fuze to the latest firmware try doing that. If your Fuze has a white screen even when its plugged in, and it doesn’t do anything with the update, you’re going to have to manually install the firmware.

THANK YOU SOOOOO SO SO SO SO SO MUCH :)

slide up ythe power swith and press home.thats what i do.:slight_smile:

I have the same problem, it’s had a white screen for weeks. I’ve tried everything and nothing works :frowning: I got it two years ago so can’t return it either…help???

@misspooh wrote:

I have the same problem, it’s had a white screen for weeks. I’ve tried everything and nothing works :frowning: I got it two years ago so can’t return it either…help???

Try pressing the Menu button at the same time as the Power switch (or a split-second afterwards). This has been known to work in some cases before.

Nah, the whole player is dead now. The battery died so I tried charging it, now it won’t even charge. Piece of junk LOL. I’m looking into buying a Zune…