White screen of death still unsolved

I have an 8 gig Fuze that I received for Christmas '08, that has aquired the WSOD. I have tried holding the power botton every which way but loose for as much as 30 seconds and updating the firmware from 22 to 26 to no avail. Am I missing something or do I need to just return it?

If the Fuze does not respond to a reset and firmware installation, it might be as hardware issue.  Call Support at 1-866-SanDisk, and they will assist you further.  The Fuze has a one-year warranty.


Thanks. I will do that.

Try putting the device on hold (while it is still turned off), plugging it into your computer, and holding the rewind button BEFORE the computer is able to recognize it.  This will force the device to use MSC mode.  From there, backup all of your music, videos, ect. (if they are not backed up already), and reformat the device on the PC.  If you see any *.bin files on the device, do not back them up.  Download the latest firmware for the device (from the Sandisk website, NOT with Sansa Updater), drag and drop the bin file to the device, unplug, and see if it updates, and works.  This worked for my white screen error that I had.  If this works, you should be able to copy your backed up data back to the device.  I hope this works for you as well as it worked for me, but I have no guarantees for you.

I was signed up to Best Buy / Rhapsody, so my computer automatically opens that page when I plug it in. I don’t know if that will make a difference, but I can find it on My Computer. I am relatively computer illiterate (sp? :slight_smile: but I will try your suggestion b4 I call SanDisk. Thanks.

I tried all of the above still to no avail. I guess it’s time to call SanDisk. Thanks for your help anyway.


ok… what’s a .bin file again? i feel kinda slow that i have to ask that but i need to know.

A .bin extension file is a binary format data file, like the Fuze firmware.  When you click on the link for the Fuze firmware, once you unzip / extract the file, it’s in a binary format.

The directions for manual firmware installation are here.


I called 1-866 SanDisk twice, and it’s not the correct phone # for Sansa support. I’m still trying to locate that phone #. Get this - on a FAQ page, one of the questions is “what is the # to Sansa tech support?”. Instead of just answering the question when you click the question, they tell you where you can find the #. B4 I could get to whatever page that was, the main internet server for this area crashed. If they had only answered the question…

@nazznate wrote:
I called 1-866 SanDisk twice, and it’s not the correct phone # for Sansa support.

Where are you located?

That is the Tech Support phone # for the US. If you’re elsewhere, try looking up the number for your area on this page.

I’m in Georgia, US. The lady who answered the phone (both times) told me that people call there alot looking for SanDisk. I wish I could remember the company she said she was with. I’ll try it again

I got SanDisk this time. They were closed but I’ll call back tomorrow. I also sent an email asking about the return process. Thank you


They should be open now… try giving them a call.