When e280 unplugged from PC, still says "Connected" and I have to do a hard shutdown

I have an e280 that has worked perfectly for several years. It has firmware version 01.02.24A. Just today it went “belly up” on me - or so I think. I plugged it into my PC via the USB cable as usual, in the MTP mode, and using Windows Media Player 11.0.5721.5280, I attempted to move some music from the PC onto the e280 using the Sync function as normal. It said it completed the task and I could disconnect the player (as usual). When I disconnected, the “Connected” screen and message remained on the player. It wouldn’t change. I finally had to hold down the Menu/Power button for 15 sec. until it turned off.

It is now not functioning correctly. Using Windows Media Player I did a “Format” to wipe out everything on the player’s drive. Disconnected it - same result. Did a hard shutdown again, and this time removed the back and disconnected the battery and reinstalled. Same problem as before. Don’t know what else to try … HELP!!!

Perform recovery mode on the player (Turn off -> Lock the player -> Press and hold the the record button and plugged it on the computer).

Thanks Jayryl for the suggestion. Tried that, but no luck. Still does the same thing, and still shows “connected” after I have disconnected it, and still have to do a hard shutdown by holding down the menu key for 15 secs. And although it will copy files over using Sync, they don’t come out with the info - just thrown into a folder called “Unknown.”

Don’t know what to try next. SOMEBODY out there is bound to know why my player is doing this, and what I can do to fix it! Does SanDisk “fix” players with problems such as this? I don’t want to thow it away and buy another one - I love my 8Gb player!

One other thought … should I put it in MSC mode and “hard format” the disk? If I do this, will I be able to reinstall the firmware if it kills it?