E280 problem

I was attempting to delete and reload  music on my player but I there was always a straggler left behind to spoil the new playlist, while try to resolve this issue the USB cable was inadvertently removed from the computer without “safely removing”. When I rebooted I get an image on the display with “Disk” on the upper left of display, icon in the middle, and “San” on the right also the ring is solid blue. While trying to resolve this issue I tried formatting from WINDOWS without success then found neutron_bob’s solution (05-18-2009) which looked promising  unfortunately when rebooting get the same result described above. I would appreciate any suggestions, neutron_bob any ideas? Or have I spawned a “brick”?

Did you try simply “resetting” it? Press and hold the power button for 20-30 seconds. Release, then press the power button again momentarily to start it up. With any luck, it should fire up normally.

This is my problem I am encountering right now…Can you give me solution…brrrrrrrrrr…single memory foam mattress


It sounds like you have a  v1 device. Do you remember, when powering up the device, if you saw a SanDisk logo with the “sunburst” logo to the right?

This is the classic logo:

The v1 machine stores the operating firmware in a reserved partition, a small 16MB section of memory. It’s possible that the firmware may have been corrupted; more specifically, the file allocation table may have a corruption, and the firmware image can’t be read properly.

If you have a later  v2 e280, it has a different processor, and a more stylized SanDisk logo, along with a blue neon  sansa logo that flashes immediately after the SanDisk appears. (The v2’s reserved partition is addressed solely by the processor, a more robust design.)

You can recover the v1 using Recovery Mode, but first, we need to verify if it’s a basic V1 or the Rhapsody model, as this firmware is different. The R series machines have a Rhapsody logo that appears in a second splash screen, right after the first SanDisk one.

Let me know which version player you have, and we can go from there. 

A word of caution regarding Recovery Mode!  Never attempt to format the device using Windows while connected in this mode, as it erases critical data.


Bob  :smileyvery-happy: