What ports need to be open on the router for Connect to connect to the Yahoo Internet radio?

Any port range you can share with us?

I have a new router - and unlike my previous router, it won’t allow the Internet radio through to my Connect… :cry:

I can see the stations alright, including the artwork for each station, but I can’t connect to the music… it says “Connecting…” for a long while, and then gives a “server error” or “Connection lost. Please press >> to retry” message or simply goes back to the station list without actually connecting anywhere…


Message Edited by Sansational on 11-24-2007 10:24 AM

This is from the Sansa Connect FAQ … although it probably doesn’t apply to your router configuration, the “MMS” bit might give you some clues …

Q: Are there any problems with D-Link Routers? My Connect won’t stream Internet Radio.
A couple D-Link routers are known to be problematic when streaming Internet Radio with your Sansa Connect. If you are unable to stream Internet Radio, your D-Link router may need one of the following configuration changes if they are available on your model:

  1. Make sure you have the latest firmware installed on your router.
  2. Enable Gaming mode: Login to your router, navigate to Tools>Misc. and then enable gaming mode.
  3. MMS Configuration: You can either disable MMS in the router firewall configuration area, or create a rule to allow traffic. Enable the following rule in Advanced>Application Rules.
  • Name: MMS
  • Trigger: 1755 Traffic Type: both
  • Firewall 1024-5000,504 Traffic Type: UDP
  • Schedule: Always

Disabling MMS blocking on my TrendNet router worked like a charm… kudos!