INTERNET RADIO: DLink 655 v1.05

I have the same problem as described in this post: http://forums.sandisk.com/sansa/board/message?board.id=connect&thread.id=73

Except my router is the D-LINK 655, firmware version 1.05.

I tried following the advice in that post without any luck.

Infact it seems D-LINK has removed the function to disable mms, etc in one of the firmware upgrades.

The Sansa connects to the router and functions in every way except for Internet radio.

I have connected to other routers (Netgear, Linksys), and the Internet Radio on the Connect would work fine.

Any help would be appreciated!

CK

Your Dlink DIR 655 problem looks more like the problem described in the SanDisk FAQ for the DIR 625 (http://sandisk.com/Retail/Default.aspx?CatID=1541#37) . In both of these routers, the AGLs seem to be the source of the problem and DLINK states the following:

ALGs provide special handling of the IP payload for some protocols and applications to make them work with network address translation (NAT). If you are having trouble using any of these applications, try both enabling and disabling the corresponding ALG.

* If the firmware no longer allows for the disabling of MMS ALG, you should contact DLINK to see how to toggle this setting.

Here is a little more specific FAQ for the D-Link Routers.  Early versions of DIR-655 had Application Gateway preselects, but after v1.05 you need to create the rule specified in below in the Advanced > Application Rules.

Q: Are there any problems with D-Link Routers? My Connect won’t stream Internet Radio.

A: Some D-Link routers are known to be problematic when streaming Internet Radio with your Sansa Connect. If you are unable to stream Internet Radio, your D-Link router may need one of the following configuration changes depending on your D-Link model and firmware.

1) Enable Gaming Mode: Login to your router, navigate to Tools>Misc. and then enable gaming mode.

  a. Affects Models DI-5xx, DI-6xx and some DI-7xx

  b. Option not available on DI-624 (rev E) & DI-624M models

2) Disable MMS Application Level Gateway support: There is a problem using this configuration option in the DIR model routers. Login to your router, navigate to Advanced>Firewall. Scroll down to Application Level Gateway Configuration and uncheck the MMS selection box.

  a. Applicable to Models DIR-625, DIR-635, DIR-660

  b. Applicable to Model DIR-655 with firmware v1.05 or lower

3) For Model DIR-655 running firmware v1.05, v1.10, v1.11 or higher (or any DIR model firmware that does not have Application Level Gateway Configuration options); Enable the following rule in Advanced>Application Rules.

     - Name: MMS

     - Trigger: 1755  Traffic Type: both

     - Firewall 1024-5000,504  Traffic Type: UDP

     - Schedule: Always

i have a dlink DIR-628 it will not let my sansa stream internet radio. it says that it is connected, then i select the station. it will then just say connecting. after a while it says connection lost.