Cannot complete connection to Yahoo Internet Radio via USR5453 AP and D-LINK DGL4100 router

I know the following is the SANDISK standard answer.  However, it is of no help.

I can connect my Sansa Connect to public wifi sites, in hotels with wifi and to open routers in my neighborhood and listen to the Internet Radio.

I have purchased a USR5453 professional access point for my home that works well with my family Windows XP and Vista PC laptop computers.  The access point is plugged into a D-Link Gigabyte switch into a DGL4100 router then into a DSL modem.  Yahoo Music Jutbox works well on my PCs. 

The Sansa Connect has connected to the Internet via the USR5453.  However, it can never complete a connection to Yahoo Internet Radio.

Q: What are the steps that the Connect performs when connecting to a WiFi network?

A: There are typically three steps when the Connect starts WiFi.

  1. FINDING NETWORKS – Available networks are identified and presented. You can select an available network or choose ‘hidden network’ (if you know the SSID of a hidden network). When you successfully connect to network, the network name and password is saved in the ‘PREFERRED NETWORKS’ list. If a Preferred Network is available, the Connect will automatically select it and send the password information to connect to it.

Not a problem.

  1. CONNECTING TO NETWORK – the Connect is authenticating and associating with the WiFi network access point. If the Connect completes this step, then you know the security settings are compatible, the password was correct and you successfully connected to the access point. If you fail this step but connected to this network before, delete the network from the ‘PREFERRED NETWORKS’ list so you can manually enter the password (as something might have changed since it was last saved).

I have verified the security settings and the proper password has been used.

No MAC filtering, WAP/WAP2 PSK personal – not enterprise – and TKIP

  1. CHECKING NETWORK – the Connect is testing network connectivity beyond the wireless access point and verifying the Zing service network is reachable. If the connection fails during this step then there is a problem with the access point internet connection or the access point diverts the connection to a ‘terms of use agreement’ web page. Some hotspots divert to a terms of use agreement web page which the Connect cannot accept.

I do not believe there is a terms of use agreement web page on my home access point.

I get the connect checkmark symbol but then appear to timeout while trying to connect to Yahoo Internet Radio.

Once connected, the access signal bars are all green at the bottom of the screen but there is only intermittent  ++ symbols above the green bars indicating an internet connection while the devise trys to content with Yahoo.

Each time I end up with Connection Lost please retry. ZING downloads just fine!!

I have reset the access point.  Changed security settings.  You name it.  I have tried it with and without MAC filtering.  Flashed the BIOS.  No success with Yahoo.  Is it in the router?

This is very frustrating.  Any suggestions?


Message Edited by leroykl on 01-17-2008 10:56 PM

After three nights of Networking HEL*, I found the answer posted in this forum.  It is a router issue.

This is a post taken from the Sansa Connect FAQ … 

Q: Are there any problems with D-Link Routers? My Connect won’t stream Internet Radio.
A: A couple D-Link routers are known to be problematic when streaming Internet Radio with your Sansa Connect. If you are unable to stream Internet Radio, your D-Link router may need one of the following configuration changes if they are available on your model:

  1. Make sure you have the latest firmware installed on your router.
  2. Enable Gaming mode: Login to your router, navigate to Tools>Misc. and then enable gaming mode.
  3. MMS Configuration: You can either disable MMS in the router firewall configuration area, or create a rule to allow traffic. Enable the following rule in Advanced>Application Rules.
  • Name: MMS
  • Trigger: 1755 Traffic Type: both
  • Firewall 1024-5000,504 Traffic Type: UDP
  • Schedule: Always

The router rule is all is took. ARGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH.  Hear my pain SanDisk.  This is what manuals are for.

Thank you again for Posting that information - My roommate and I just installed a new D-Link DGL-4500 Gaming router - works amazing; but we did run into the same streaming problem with my Sansa Connect.

I went into the “Special Applications” and added the MMS Rule and port information as described above - Works like a clock!

I have a screenshot if anyone needs it - I figured I could upload it here but I do not see how.

Anyway - Thanks again for the 3 days of Hel*P :slight_smile:

Steve R

…there is lots of good info in the FAQs…

Steve - Did you have to change any other settings? I also have a DGL-4500 with that special application entry and no luck. By gaming enabled, would that be gamefuel for our router?

Thanks for any help.


Ahh, finally got it with those settings and WPA TKIP. I made my network public while testing because I got tired of entering the password. Turned it back on when I was about to give up and tried one more time and it worked!? Gotta love technology. LOL :stuck_out_tongue: