Another Connect WIFI Question

I have loaded the WIFI software from the recovery program as explained by Promised Planet. I can connect to my wireless rotor. I have a Yahoo ID. But the unit doesn’t make the connection. So, I have a few question I’m hoping someone can assist with. 1- Any ideas why the unit will not establish connection to the radio service which I read is still available ? 2-Is it necessary to have a special configuration within my Yahoo account ? 3- I understand that Yahoo moved there service over to CBS radio to provide stations to listen to. Is a different login from the Connect unit required for the CBS radio service ? Thanks in advance for your assistance… Soundsgood57

1a) What error do you get?

1b) Sometimes the audio stream servers are down … I’ve had this happen to me maybe 1 out of 10 times I’ve attempted to connect.

  1. No.

  2. No.

Connection timed out… using the “My Station” selection…

Actually the “My Station” selection used to access a customized station, but has been disabled.  If you select it, all you get is a text screen with old information about “My Station”, no actual audio.

After selecting Internet Radio, do you see the other categories under “My Station”?  They are:

Favorite Stations


If you do, and you select Genres, do you see a list of sub-genres (pop, rock, etc.), and if you select a sub-genre, do you see a list of stations?

Also, log into the same Yahoo account and verify that you can play a station at

Message Edited by PromisedPlanet on 12-08-2009 04:04 PM

Yes, I see the sub-genres… I selected one and entered my ID and password but the same result… Connection Timed out

2- I went to yahoo directly login and was able to play the same station I had selected on the connect unit…

Strange.  I’d suggest connecting to another WiFi network and see if you get the same error.  If you do, there’s probably a problem with your Connect, otherwise it may be your network/router configuration.

I know you said you can connect to your router, but I have to ask anyway - do you have MAC Filtering enabled on your router?

Message Edited by PromisedPlanet on 12-08-2009 04:22 PM

Well, I don’t know if the rotor has MAC filtering enabled… what should it be set at ?  As for another WIFI network, are you referring fine another rotor to hook into ?

Every device which can communicate on a network has a MAC address, which uniquely identifies the device.  The Sansa Connect’s MAC address can be seen under Settings -> WiFi -> WiFi Status.

A router can have MAC filtering disabled, in which case any device can try to connect to it, or the router can have MAC filtering enabled, in which case you would then configure the router with a list of MAC addresses that can attempt to connect to your it.  If you have MAC filtering enabled, but the Sansa Connect’s MAC address is not on that list, it won’t be able to connect to your router.

“As for another WIFI network, are you referring fine another rotor to hook into ?”

Yes.  If you live in any relatively populated area, you should be able to walk around and find a bunch of unprotected WiFi networks.  Apartment complex parking lots are good places to try it out.

Message Edited by PromisedPlanet on 12-08-2009 05:02 PM

I’m pretty sure it’s MAC setting default is ‘disabled’ but I will check that later… But I do get the signal strengh icon next to the battery icon  after the unit indicates it’s connected to the rotor… it knows the brand name of the rotor… so I’m pretty sure it’s connected …

Yeah, it doesn’t sound like MAC filtering is the issue.  Best test to perform now would be to try a different WiFi network.