Want Safe Ejection of a Cruzer Edge 8GB

Using Win7 Pro64 and having gone through, “http://kb.sandisk.com/app/answers/detail/a_id/309/~/safely-removing-the-usb-device-from-the-computer twice; once on my own then as referred to by, SanDisk Chat” I still can not get my ‘thumb drive’ to eject in the customary manner.

Because ‘Right Clicking’ on the listing in Windows Explorer did not have a “Safe Ejection” entry, I have used a ‘Shortcut’ to, “C:\Windows\System32\rundll32.exe shell32.dll,Control_RunDLL hotplug.dll” and ended with, “The ‘SanDisk Cruzer Edge USB Device’ device is not removable and cannot be ejected or unplugged.”

This not at all what i thought I was buying when I obtained a card of four ‘Cruzers.’ Has anyone found a way around this?

Worst comes to worst, shut down the machine, then remove the Cruzer and reboot.

In Windows Explorer does the Cruzer show as a Removable Disk or a Fixed Disk?  Did you possibly select the Windows ReadyBoost option in the Windows AutoPlay window when you plugged it in?

Windows Explorer definetly does not announce/label the Cruzer as “Removable.” I do not recall changing anything on the first auto-detect but then I have reformatted one of the four drives as NTFS from FAT32. But all Cruzers are seen as, “Non removable.” whether NTFS or FAT32. There must be a Registry entry that identifies whether or not an le oUSB device is removable.

"But all Cruzers are seen as, “Non removable.” whether NTFS or FAT32."

If you RIGHT click on one then on Properties what Type does the Properties window’s General tab show? 

On the Properties window’s Hardware tab click on the SanDisk drive’s name then click on the Properties button at the bottom of the window.  On the Device Properties window click on the Policies tab.  What policy options are enabled?

I have Safe Ejection again:

Here’s how I cleared my problem by using an untouched, fresh new, Cruzer 8GB:

i) I saved everything on the NTFS reformatted & renamed Cruzer 8GB which Win7 reported as non-removale after I 'messed with it.

ii) I copied everything from a FAT32 formatted, freshly purchased, Cruzer 8GB, which Win7 reported as removable to the drive in i)

             now the drive in i) was reported as removable

iv) Finally I replaced the data saved in Step i) above, onto the problem Cruzer drive

Guess I’ll put up with the extra files. This is much better than rebooting each time i wish to remove a ‘thumb drive’; even though I have a faster booting SSD C: drive.

So thanks for the attempts to clear my puzzle.

I’m happy to hear you got your problem resolved but I’m confused by what you wrote.

i) You saved everything on the NTFS Cruzer reported as non-removable.

ii) You copied files from  a new Cruzer to the drive in i).  These I assume are SecureAccess files? 

iii) Then the drive in i) is reported as removable!!

That doesn’t make sense to me.  Did you reformat the drive in i)?  Delete all the files on i)?  There has to be something you did that I’m not getting.

Sorry I wsas not clear. Please try this explanation:

l) I temporarily moved all the files from the problematic Cruzer to my hard drive; that left an empty Cruzer formatted as NTFS

ii) I checked the other Cruzers that I bought and found one that Window saw as removable

iii I copied all of the files on this last ejectable drive to the emptied emptied non-ejectable drive

iv) I move the saved files back onto the problematic Cruzer and reboot then recheck

Voila! Problem seemingly gone   ,    but    …   It’s now again back.

I now note that on insertion Vipre sees both Cruzers as removable which should be scanned.

But WinEplorer sees one removable Cruzer and one non-removable

I will retry this procedure and even reformat the non-removable drive as FAT32

More posting(s0 later

Next tests:

I: i) Moved files from NRD (non-removable drive) to hard drive

  ii) reformatted NRD as FAT32 default block size and checked to find  - still an NRD

II: i) Used Spoymau 2012 to clone an  RD (removable drive) to the NRDand checked to find -  still an NRD

I have downloaded but not yet set up "Clonezilla so that I can try a bit-by-bit cloning.

I’ll write more later - family duties now.

This could possibly be a behavior on the specific desktop only. But have you tried other desktops or laptops and see if it behaves the same way?

Same thing happened to me.  Cruzer jump drive says it is not removable.  This followed using it to run recovery effort on a problematic laptop.  The cruzer was used to repair the laptop windows 10 os and seems to have done a good job (have iso image on the cruzer to use for the above purpose).  Now I get a message returned that it is not removable when I try to safely eject it.  Is the pc reading the iso image (windows 10) that is on the cruzer as now being my system files or a similar problem, do you think?  I haven’t tried shutting down and removing in case the laptop now thinks it “needs” the information/iso on the cruzer to even boot.  Any help or thoughts would help,  Thanks

Safely Remove ensures any writes sitting in a Windows buffer gets written to the drive.  These writes could be very small, like an update to a file directory entry, but could be very critical to the data on the drive being usable.  If Windows says the drive is not removable means something has a file or folder open on the drive.  Be sure everything using the drive is closed.  If unable to determine what is using the drive shutting down Windows works.  And I don’t mean turning the system off, I mean shutting it down.