Vista machine will not install device driver for Fuze

I purchased this Fuze for my wife. When I connected the player to my Vista OS computer, the system tried to install the device driver for the player. It would not do this. My computer will not recognize the player in MTP mode. In MSC mode, the computer sees the player but Rhapsody does not. I have been able to update the player software but it has not helped. FYI: this computer has no problems with my Sansa E200R. I don’t know why it should with this player.

Do you have Windows Media Player 11?

The Sansa Rhapsody e200R has a secret weapon: it is talking in MSC mode and using RAX format audio files.

The Secure WMA required for the newer Rhapsody compatible device needs MTP mode and Windows Media Player 11 includes the drivers for this mode.

The problem is our little friend Vista has WiMP bolted in.  Try connecting in MTP mode (Settings> System Settings > USB Mode > MTP) manually, then go to the Device Manager on your PC.  The Sansa should appear with the wee yellow triangle of doom, listed under Portable Device.

Uninstall the device, then unplug.  (I prefer to reboot at this point)  Then after the PC is booted up, plug in the Sansa again, and it should install the proper driver automatically.

Bob  :smileyvery-happy:


the same thing happened to me with my fuze.

the msc mode works, while the mtp mode does not. 

i tried what you instructed several times, but nothing has worked.

please reply to help! that would be much appreciated.