Two Issues with Sansa Fuze (installation CD and MTP mode)

I have a Sansa Fuze (model #:BH0807AXVK-4GB) that came with an installation disc that will not work (it says “installation CD Version: 1.0” and “Contents: Rhapsody Media Manager” ). My computer will not recognize it. Furthermore, my computer will not recognize the Fuze as an mp3 player. In MSC mode, it appears (As well as the micro SD card), but I don’t want to drag+drop all of the music I plan on putting on the mp3 player since it’s a lot. In MTP mode nothing happens (my mouse shows activity for about one second, that’s it).

I upgraded the firmware and downloaded the driver from your official site (as well as the converter and user guide). I also tried to download this hotfix from Microsoft ( ,, “FIX: Windows Media Player cannot synchronize media to an MTP-capable device on a Windows-Vista based computer” ), but received an error message saying “The update does not apply to your system”. I’m running Windows Vista Home Premium 32-bit (w/ Service Pack 2). I tried both options, but neither worked. Can I receive help with this matter?

Message Edited by ryan_bigl on 11-01-2009 07:49 AM

You should be aware that most of the people who participate in this forum are not SanDisk employees, but users like you. You may get help with your problem here, or it may turn out that your problem is with Microsloth  _ Mala _ Vista  :wink:, but if you eventually want to communicate with Sansa customer service, you should probably go to the site.

You can make the connection in MSC so the cord and port are working. Good.

Why you want to deal with the many quirks of Windows Media Player rather than doing simple drag-and-drop is beyond me, but…

In Settings/System Settings/USB Mode change it to MTP (not Auto detect). 

The MTP driver is in Windows Media Player 10 or 11. Connect the Fuze, go to Device Manager, and see if there are any USB devices with a yellow triangle holding an exclamation point. Uninstall them, reboot, try connecting the Fuze again. 

If that doesn’t work, try upgrading or reinstalling Windows Media Player 10 or 11–whatever Vista will let you do–and then try connecting again. And try all the ports. If you have installed some games–Xbox? PSP? I forget–sometimes WMP gets jealous and won’t let you use the port. 

And if for some unknown reason WMP just doesn’t want to see the Fuze, go back to MSC mode and use Media Monkey or Winamp to sync your music to it.