Connection Problems, please help!

Hello all.

I’ve had my 4gb Fuze since summer and had no problems with it, always synching through windows media player.  Recently, however, I’ve been having a synching problem.  This, however, appears to be due to my computer rather than the player, but I figured I’d try asking here, anyway.  On my laptop, the device is not recognized at all when the USB mode is auto-detect, and does not work in MTP mode.  Only by switching to MSC mode can I access it.  I cannot view any of the files on it through Windows Explorer, though I can still synch files to both it and the card as mass storage devices through Windows Media Player, after telling it to treat the devices as media players.  These problems developed shortly, though not immediately, after purchasing an 8gb microSD card and upgrading the FW.  

The Fuze seems to work fine on other computers, showing up as a Sansa Fuze with its picture and everything w/o any software installation needed.  I’ve tried the basic things on my laptop such as reinstalling WMP 10, upgrading to WMP 11, running a virus scan, adware scan, checking for any conflicting programs, uninstalling the USB drivers and letting them reinstall, etc.  Other USB devices give me no trouble, though I have no other MTP-enabled devices on hand I can test with it.  Short of reformatting the hard drive, which isn’t worth it in this case, what suggestions can you give me to get my laptop to work with my Fuze again?

Sorry that I’m asking this here, as it is a problem with my laptop rather than the player, but I figured it would still be a good place to get some insight, thanks!

Okay, well, still no thoughts I see, but I have some more info.  All I have to do is plug it in to another computer and after a minute to auto-download the drivers, everything comes up like its supposed to.  But still on my laptop I have to force it to MSC mode, and even that doesn’t always work.  I still can’t go into the Music folder, it just says the folder is empty (though it does recognize the used capacity of the player when I go up a level to look at all the drives).  Uninstalling the USB drivers and letting them rebuild them has yet to work.  If I plug it in in auto-mode or MTP, it WILL begin to be recognized, but then won’t work, and if I go into the device manager, I see the driver under portable devices.  However, there’s a yellow exclamation point over it, and in properties it says the device cannot be started.  No matter how many times I uninstall it and plug the Sansa back in to let it reinstall, I get the same problem.  Please, someone must know how I can fix this without reformatting my HDD!

Message Edited by Cruiserdude on 11-24-2008 04:54 PM

Search this threadfor MTP Porting Kit and hotfix.  One or the other might help. No guarantees. Are you on XP or Vista?


It worked fine before, and works fine on other XP SP3 machines, haven’t tried it on Vista yet.  Thanks for those links, not sure if any of those are Vista compatible?  I may try it anyway just to see…

Alright, the MTP porting kit didn’t change anything, and the hotfix was for Vista only.  I’ve found that while I can see the folders and used capacity in MSC mode with both Windows Explorer and Windows Media Player, all of the individual folders are shown as empty, no matter what I do.  My microSD card is find recognizes it no problems, can add or copy files as desired (though the player has to be in MSC mode).  The only problem is I can’t access the files on the device itself with my computer!  I ran chkdsk on the drive, and all the files were recognized, format was FAT32, filesystem was intact, etc.  So no problems there.  I’ve tried deleting the M_table.sys file (the media directory) and letting it rebuild, with no change.  Once I can get my hands on another computer with USB 2.0 and a dvd burner (my home desktop is not…) I’ll try making a backup and then reformatting the player.  Hopefully that will fix the problem, but I still can’t figure out how it works on other computers but not mine, and I haven’t changed anything recently…

Sansa players have the somewhat bizarre feature that files transferred to internal memory via MTP are not visible to the PC in MSC mode and vice versa. The restriction does not apply to files on the uSD…

In MTP mode, does your player show up in XP’s device manager at all? Even if only as a yellow question mark?

@cruiserdude wrote:
. . . if I go into the device manager, I see the driver under portable devices.  However, there’s a yellow exclamation point over it, and in properties it says the device cannot be started.  No matter how many times I uninstall it and plug the Sansa back in to let it reinstall, I get the same problem. 

You didn’t say so you may already be doing this, but make sure after you un-install (not just dis-enable) in Device Manger, you disconnect your player and re-boot your computer. Then, plug your player back in and let Windows discover it as ‘new hardware’.

Hmm, that’s odd, because yes, I transferred all the files to it through MTP, and when I force it to MSC, I don’t see the files.  When I set it to MTP, it does nothing.  When I set it to MSC only, then yes, I can see the player and card through both WMP and Explorer, but I can only see the files and transfer them to and from the card, so that goes along with what you said.  When I plug it in auto-detect mode, it will appear to be connecting, often the little window will come up asking what I want to do, but it typically goes away before I can open anything, and Device Manager shows an exclamation point over the driver, w/ an error code 10 (device cannot be started).  I’ll uninstall the driver, unplug the player, and plug it back in, and if I do this process several times in a row, I’ll sometimes be able to get it to stay connected long enough to look at the folders and their contents in Explorer, but after awhile it usually closes suddenly and disappears from My Computer, and I get that exclamation point again. 

Yesterday, however, I was able to keep the connection open long enough to copy all 3.7 gigs on the player over to my hard drive.  Ironically, however, I still could not see the player OR card on Windows Media Player at this time.  The only way I’ve been able to transfer songs recently was to hook it up in MSC mode, and add files to the card through WMP.

BTW, thanks Tapeworm, I don’t always do that.  I’ve found that when I uninstall ALL the USB hosts and the sansa driver, then reboot, and then plug it back in (in Auto-Detect mode), it often works longer (that’s how I backed it up yesterday), but WMP still won’t see it, I have to use Windows Explorer.  However, I can get the same results by just uninstalling and reinstalling the Sansa driver a few times in a row without rebooting, so I’m really confused here…

Well, been trying stuff all night, with no change in the symptoms.  I did reformat the device, first on my computer (as FAT32 of course, using HP USB format tool), then on the device itself.  However, it turns out that like some said earlier, I can access the player with no problems in MSC mode, I just couldn’t see the songs before, because I had loaded them in MTP.  Unfortunately, I could not load my backup onto the Sansa through MSC, as I had originally put it on there through MTP, and the files refused to copy.

However, after equalizing all my music with mp3 gain (had no effect on the issue I’m sure, but I did do this as it was convenient at the time), I copied my Sansa backup over to my microSD card, as I had about 6 gigs left on an 8gig card.  All the files transferred over, but of course took longer to organize.  I have since found that I can now transfer the files from the card to the player through explorer.  Haven’t yet tried synching directly to the player with WMP in MSC mode, but I will soon.  Regardless, I still can’t figure out why I suddenly lost the ability to use MTP mode just on my laptop no matter what I tried, and would really like to get it back.  However, as I’m unlikely to use any DRM protected content, as long as I can use MSC I should be fine for now.  I’ll keep y’all posted as I continue sorting this out…

@cruiserdude wrote:

Unfortunately, I could not load my backup onto the Sansa through MSC, as I had originally put it on there through MTP, and the files refused to copy.

AFAIK, when you copy stuff off via MTP, they end up being ordinary OS files, no magic happens to stop you copying off via MTP and back via MSC. In fact I’ve just done it to prove it works…

Just a wild guess, but are you sure there is not a hardware issue with your USB port, or cable? If there is some intermittent failure, I think it is more likely to affect MTP than MSC at start up, because there is a shed load of messaging that happens when you connect an MTP device. If that is interrupted, maybe the MTP device driver gives up and flags an error?

Maybe the same intermittency is the reason you couldn’t copy all your files back to the player in MSC mode?

Well, I’m pretty sure its not a problem with a USB port, as I’ve tried it on all the ports, reinstalled the drivers several times, and have no trouble using other USB devices through the ports (or the player itself in MSC mode).  What’s wierd is it will sometimes load in MTP mode, and I’ll see the picture of the Sansa in both WE and WMP, and it’ll even work for a bit, but unvariably will suddenly disappear in less than a minute.  Cable’s fine, it works no problem in MTP mode on other computers.  I was able to put the files back on the player in MSC mode, but I had to copy them to the card first, then move them over.  I’m not having any trouble using the device in MSC mode, and I should probably use that from now on, but it just seems wierd that MTP no longer works, when it used to give me no trouble?

Hello Cruiserdude.

I just had a thought regarding the troublesome XP based computer and a loss of MTP mode.  Check this thread regarding a similar situation.  Perhaps the command may make a difference in your case.

Check drlucky’s post just above the highlighted one.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 11-27-2008 07:49 AM