Computer not recognizing Sansa Fuze - SOLVED!


I thought Id share my experience of how I fixed the problem of my computer not detecting my Sansa Fuze, because it seems like alot of people are having the same problem.

I received my Fuze in the post today. I bought it new over ebay from a dealer in Sydney and its wicked… but I was shattered to discover that when I plugged it into my PC I was unable to access it, or see an icon anywhere. When I first plugged it into my PC I got a message saying ‘new hardware found… installing driver. Then I got a message saying ‘this device may not be working properly’.

I searched the forums here and did all the things people suggested:

I knew that my system met the minimum requirements and that I was running Windows Media Player 11. I tried soft resetting (hold off button for 10 secs), formatting, resetting to factory standards, I rebooted my PC several times etc… none of this worked.

Next I looked in the Device Manager and this is where I was able to fix the problem. (Right click My Computer  >  properties >  Hardware’ tab  >  click ‘Device Manager’)

I noticed that when my Fuze was connected to the PC there was an entry under ‘Universal Serial Bus Controllers’ in Device Manager which said ‘Mass Storage Device’ and it had an exclamation mark next to it. When I right clicked, it said… ‘this device is not working properly’. (This was my troubled Fuze obviously and for what ever reason the drivers that windows had installed for it were not working properly).

So I Right clicked on the Mass Storage Device icon and selected ‘uninstall’… then OK’ed it.

Next I shut down my PC and disconnected the Fuze  > Reboot PC with Fuze disconnected.

Turn Fuze on (Don’t connect it yet). Go into the settings  >  System Settings  >  USB Mode  >  change from default ‘Auto’ to second option ‘MTP’

Then connect your Fuze to the PC.

When I did this my PC detected the Fuze and was able to install a correct driver for it…

Go back into the Fuze Settings and change USB Mode back to ‘Auto’.

Having done this my PC recognizes the Fuze everytime and it shows up as a portable device in Windows Media Player… However Im still having trouble getting Winamp to behave properly with it!

That went a long way to fixing the issue for me… hopefully it will work for others too.


Message Edited by Lukas101 on 07-30-2008 03:37 AM

THANK YOU. I was getting so frustrated when it wasn’t getting recognized. This method worked flawlessly for me. Thanks again.

I think MTP is a microsoft protocol.

If you are using a windows machine, please just use MTP since it works better on Microsoft Operating System.

didn’t work

Message Edited by HassanB on 03-18-2009 02:44 PM

@kevin02454 wrote:


I think MTP is a microsoft protocol.


If you are using a windows machine, please just use MTP since it works better on Microsoft Operating System.


MTP == Media Trasfer Protocol.

Yes, it’s developed by M$, but that doesn’t force you to use it on Windows PCs.

MTP is also supported via libmtp on Linux & MacOS, but YMMV.

It is now an open USB device standard.

MSC == Mass Storage Class

Makes your Fuze look like a USB disk drive - and therefore useable on just about any computer with hardware & OS less than 10 years old.

Auto == try MTP and fall back to MSC if it doesn’t work.

Relies on some non-standard M$ jiggery-pokery that Windows does when a USB device is plugged in. Probably best avoided, then at least you knowhow you expect the player to connect.

i tried it hoping can solve me the battery charge problem, but nothing, my mattery want charging only for 2 minutes than seems full of charge, in MSC mode i have the same , but in 10-15 seconds.

Sounds like a faulty battery. If the retailer will replace, do that, else get an RMA from Sandisk support via an EBox:

Message Edited by daytona955 on 05-01-2009 02:18 AM

I tried your trick, but Windows can’t find any drivers for my device and the sandisk website isn’t terribly helpful either.

Is there a set of drivers I can download somewhere?

@daytona955 wrote:

Sounds like a faulty battery. If the retailer will replace, do that, else get an RMA from Sandisk support via an EBox:

Message Edited by daytona955 on 05-01-2009 02:18 AM

the first one had this, the replacemets have this too.

what can i do?


I would try this, but there is absolutely no sign that my Sansa is plugged into my computer, except for the fact that IT says it’s connected.

I have a Windows XP, I have Windows Media Player 10, I have NO sound card, ummm… what else?

Now, I know my Fuze does work, cuz i’ve taken it to school with me and put music on it, but at my own computer it doesn’t even show that there is a “Mass Storage Device” or any such thing connected.  

It’s driving me nutz.

If anyone has any suggestions as to what to do, that would be grand.

After trying EVERYTHING suggested, I was still unable to "make contact ".   I then remembered I’d gone through something like this before and after swithing to a different USB Port I had instant success!  I was using a 4-Port USB Hub (USB 2?) but without success.  After plugging into a Port directly on the back of the tower it worked.  I had this problem before with a USB mouse.  It refused to work on the back USB Port but would work fine on the front Port.  Freaky!

My Fix for computer not recognizing Sansa Fuze

Go to:

faq #9 computer not recognizing sansa fuze

Follow instructions for Solutions 1, 3, & 4 if using WindowsXP.

This fixed it for me.

I changed my sansa setting back to Auto mode when finished and it still works.


My Fix for my Sansa Fuze not being recognized by my Sony Vaio Laptop running Windows Vista. It worked at one point and didn’t work after that.


Go to System Properties > Device Manager and look for a red or yellow indicator from the system letting you know that there is some type of device error for your device. The device manager will always let you know if your device is “truly” unrecognized. If it’s not there, you got a more serious problem. Mine was there and I had a yellow exclamation point. There was a message stating: "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

Click ‘Check for solutions’ to send data about this device to Microsoft and to see if there is a solution available." I chose “Check for Solutions,” but it found none. I then clicked on the drivers tab and tried to make sure that they were up to date and they were. 

Most of the time, unless the device is defective or you damage the unit, it will most likely be a driver issue. I chose to uninstall the driver (advanced) under the driver tab. The device manager no longer recognized the device at all after I did that. I DID NOT unplug the device from the usb or disconnect the mp3 in any way. I simply held the power off button until it powered off (thinking since driver is no longer there, whatever was corrupt is probably now removed and since there is no driver available the pcc will automatically search for the best driver upon recognizing that there wasn’t one). I then powered it back on and the pc immediately recognized the device and it’s misssing driver and it began searching for the best driver available (this beats looking for a site with an acceptable, free driver as well) and loaded it and the pc then proceeded to give me the on screen prompt, asking what I wanted to do with my device. 

I hope this helps you.  I was most relievd to see this solve my issue. 

Good Luck :smiley:

A big thank you to Nabiyah1. This method worked for me. Sansa Fuze, IBM Thinkpad T40, Windows XP.

OMG! YOU saved my life!!!  I was having this problem and your post was a miracle!!!



I keep getting New Hardware Found Wizard for the MTP. How can I get ridd of this. I have been running it on MSC but how can I go back. I don’t have a disk, and my PC Win XP keeps growling at me for it. I also found my Sansa Fuze under “Protable Device” and I had it uninstalled. And it kept asking me for the same thing…A DISK

I went to microsoft and downloaded a Media Transfter Protocol (MTP) and it did not help I didnt notice any thing.


Try the other side of this equation: MTP is part of Windows Media Player 10 and 11.

Open Windows Media Player, then check Help > Check For Updates, and install WiMP 11.  That’s all the driver you’ll ever need. 

Bob  :smileyvery-happy:

I have WMP 11 but I went to the MCSFT web site, and had WMP 11 reinstalled and IT WORKED I have my FUZE ( my PRIDE and JOY) back again.

I reinstalled WMP and it worked I listed it all down and I have you a shout out.


I registered just to thank Nabiyah1 for solving my problem. Followed that step by step and my Fuze is now charging through the usb cable again!