having loads of problems

I just bought this Fuze about an hour ago, I plugged it into my computer, I downloaded the firmware, the drivers, everything. I even switched the USB mode and my computer is still not recognizing the player. I am already getting frustrated with this thing, if I dont get this figured out in about an hour it is going back to the store and ill never buy sandisk anything again.

Patience, grasshopper.

The Sansa is capable of communicating in two USB modes.  Go to Settings > System Settings > USB Mode > MSC.

The device will communicate most easily in this mode.  MTP mode is needed for DRM / protected media like Audible, Rhapsody, Napster, etc.

MTP mode requires a minimum of Windows XP and Windows Media Player 10 / 11 being better.

No special drivers are needed except the resident MTP system for DRM, which is part of Windows Media Player.

On the computer, open a Windows Explorer window via My Computer or [Windows Key] + E, and plug in the Fuze.  See if it shows op as two drives under “devices with removable storage”.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 12-02-2008 11:20 PM

Hi, I’m brand new to the Fuze and this forum too, and I have been having the same problem.  I tried it on a couple different USB ports on my desktop and also on my laptop at home, and couldn’t get it to charge or be recognized.  But just now I tried my laptop at work (a different laptop) and it is happily charging away. And it is identified in the directory. 

This doesn’t really solve my problem, as I can’t use my work laptop for storing music files.  I will try plugging it into a USB port on the back of my home desktop, as is suggested in the manual.  (I hate crawling around under the desk.)

Edited to add:  I’ll take a look at the USB mode too, once it’s charged up enough.

Message Edited by SuZen on 12-03-2008 05:07 AM

If you have to crawl under your desk to get at your USB port you might want to get a USB hub. That way you only have to crawl back under there once more to plug in the hub, then you’ll have the hub itself sitting on top of your desk and you can connect / disconnect from your chair.

As far as getting your computer to recognize your Fuze, have you tried double-clicking on “My Computer” and seeing if the Fuze appears as a new drive? If so, you can right-click on that new drive icon and select “Explore” and get at it that way.

And the recharging issue - I was having trouble charging my Clip on a computer when I was visiting my cousin, and discovered that when the computer went into screensaver mode it also shut down the USB ports. Disabling the screensaver fixed that problem. 

I do have a USB hub!  The Fuze didn’t charge with the hub either.  The screensaver was not on.  It didn’t appear on “My Computer.”

I’m thinking the MSC mode might be the answer.  Didn’t get a chance to try it last night.

I am having the same problem. I have tried changing the USB mode, Tried the installable patch, the command line thing, reset the fuze, reinstalled drivers, reinstalled WMP, reinstalled the entire XP system, tried it in the front\back USB ports and still get the same error message. Unknown Device. System is an Emachine T5036 with XP sp2 highspeed USB 2.0 WMP v. 10 and basically nothing else installed onto the system. Oh, I also disabled power save mode on the USB hubs to see if that was a problem. I dont get it the system is picking up that there is something connected to the USB. So its got to be software\driver related right? Windows is good for screwing stuff up, but everything else I have tried with the USB ports works ok. So I am definatly NOT impressed with sandisk right now. All system requirements on my part have been met, yet I am stuck with a device that simply does not work as advertised. Even if I do eventually get it to work, This is an overwhelming amount of effort to get it to do so, And thus will likely be the last sandisk product that I will ever own.

Trust me on this issue, don’t be mad at SanDisk, be mad at Microsoft for rolling the MTP system to market without making a few major points easily self-repairable.  The MTP system is a necessary evil that could have been implemented so much better.  Browse the boards of any portable device maker and you’ll see the same frustrations.

Try a simple experiment:

On the Fuze, go to Settings > System Settings > USB Mode > and select MSC.

Before plugging in your Fuze, press the [Windows key] + E to open a windows explorer window, or go to My Computer.  Do you have the window open?  You will see the drives listed.

Now plug in the Fuze.  In a few seconds, the Fuze will display the rolling connected logo, and it should appear under “devices with removable storage” as a pair of flash drives.  If it does, the Fuze is performing correctly. 

Double click on the listing E: SANSA FUZE (for example, the drive letter may be different), or the first letter alphabetically assigned to the Fuze.  In this mode, as long as your music is not “protected media”, all you need do is drag your MP3, WMA, FLAC, or OGG files to the Fuze.  It’s best to transfer them to the Music folder, keeping the root directory clear.

As long as they have valid ID3 version 2.3 tags, with ISO 8859-1 (Latin-1) characters in them, the Fuze will find your music.

Now, for the purpose of this experiment, unplug your Fuze (click on the “safely remove hardware” icon in the system tray, or right click on the Fuze and select Eject).

On the Fuze, let’s try MTP mode, where you most likely are having trouble.  I must state at this point that MTP is designed as a “virtual mode”, addressing your player as a Media Device, rather than a simple flash drive.  MTP, or Media Transfer Protocol, is needed for protected media with DRM embedded tracks, like Rhapsody, Napster, Audible, Overdrive, etc.  MTP does things in the background as well…

Select Settings > System Settings > USB Mode > MTP.  You’ll see Auto Detect as the first choice on the Fuze.  Thsi mode lets the Sansa “peek” at the installed operating system on the host computer, and it will try to connect in MTP if it’s available.  For now, manually select MTP, and we’ll give it a whirl.

Is the Windows Explorer window still open?

Plug in the Fuze.  Watch the display on the device.  You should see the swirling connected logo.

Does the device appear under other as a media device?  If not, it’s NOT the Fuze, as we saw it communicating in MSC mode, it’s the Windows Media Player engine that is giving you troubles.

My best recommendation is to install WiMP 11, as the updated player seems to function better in this regard.

For now, let’s give WiMP 10 a shot at it:  Let’s go to the Device Manager.  Be sure that the Fuze is still connected in MTP mode.

Go to the device manager in one of two ways: Control Panel > System (double click) > hardware tab > Device Manager.  Depending upon your computer’s mood (yes, “mood” was added into Windows since Windows 95, trust me!), the Sansa may be listed under the listing Portable Devices.  If so, expand it, and you’ll see the Fuze.  If there’s a yellow triangle here, there are several paths you can take.  The easiest is to right-click on the triangled listing, and select uninstall.

Do NOT select “disable” as all this does is tell Windows to ignore the device.

Once it’s uninstalled, unplug, reboot the computer, and plug in MTP mode again once the computer is running smoothly.

Now for a footnote:  if you do NOT see the Fuze listed under Portable Devices, let’s have some fun looking into Microsoft’s little USB web.  The Sansa is almost always dangling on the last USB root hub position.  Expand the listing: Universal Serial Bus Controllers.

Do you see any wee yellow triangle of doom?  Otherwise, have a look at the positions, starting with the LAST one.  If you double click on it, a window will pop up, but you’ll not see the Sansa yet.  Select, of all things, the Power tab.  You should see the Sansa listed if it’s the device on the line.  Click on the Driver tab next, and select Uninstall.

Same thing: unplug, reboot, and plug in again.  The Sansa drivers are part of WiMP 10 / 11.

If it is now listed in the Windows Explorer window as a Fuze, under other , with no drive letter, you’re successfully in MTP mode.

If unsuccessful, download the MTP Porting Kit from Microsoft, and install Windows Media Player 11, or at least reinstall version 10.

Let us know if your Fuze is talking in MSC, and if you need MTP for your media.  We’ve all had various issues with it, and there are plenty of users here more than willing to help you enjoy your new Sansa!

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 12-05-2008 12:29 AM

Thanks for the quick reply Bob, I know all to well about the incompetance of microsofts structures… I do get a quick flash of the yellow triangle when it says it is installing a new USB device, but then it simply states it is an unknown device, and that there is no drivers associated with it. I have tried this in all USB modes. The power tab does show an “unknown device” connected (via the device manager - usb controllers ) I have tried the MTP porting kit with no success, as well as reinstalling WMP 10. I will attempt to install version 11 in the morning - dialup ISP will take all night to download and install it :frowning: If not I will be taking it back for a refund. Oh, and I checked and the USB are rated at 500ma and the fuze is fully charged via an ac adaptor. I also do get the connected screen on the fuze display as well. Any other thoughts that I may be overlooking? I would really prefer to get it to work, but as stated, will still be very disappointed in the complexity of it all.

Nope, WMP V.11 didnt help at all either. Junk in my opinion, and will be refering that to anyone who I know is considering buying one. Will be taking it back.

there is no 100% reliable product in the world… you happened to get a lemon

@eaglle1337 wrote:
there is no 100% reliable product in the world… you happened to get a lemon

Agreed!