New To Sansa Fuze And Having Problems

My BF Got A Sansa Fuze And We Have Tried To Get My Computer To Reconize It.I Have XP Service Pack 2 And I Have Other MP3 Players That Hook Right Up, But This One Is Giving Me Problems.I Have Tried Installing The Latest Firmware And It Can’t Finish Cause The Computer Doesn’t Reconize It.HELP!!!

It Won’t Even Charge…What Am I Doing Wrong? Or Is This A Faulty MP3?

Thanks Inadvance.


If you are using a desktop pc, then connect it to a USB port in the rear. If you have a notebook, make sure it is plugged into AC power when you connect. Go into the player menu and select MSC for the USB mode, then connect the player and see if it is recognized.

Most connection problems involve MTP rather then just the device. 

Before plugging in the Fuze, go to the main menu, and select Settings > System Settings > USB Mode > MSC and press the center button to select.

Plug in the Fuze and see if it is recognized.

MTP, or Media Transfer Protocol, is needed for compatibility with Windows Media DRM and protected media such as Rhapsody, Napster, and Audible books.

If you need this mode for functionality, after charging your new Fuze for a while (note the battery icon on the device), you can unplug the device and switch it to MTP mode using the method above.

This link runs to the knowledge baseregarding the MTP connection.  You will find helpful steps there, plus right here on the forum.  The “search box” above is a handy tool to find user tips and tricks.

Welcome to the Sansa community!