Sansa Fuze Wont Charge! HELP!!!!!!!!!!!!!!!!!!!!!!!

I had my sansa fuze since last Christmas.

The first time my sansa fuze wouldnt charge I came here and someone told me to hook it up to the back USB port because it has more power.

So I got this new computer just recently and my computer cant recognize it. I tried uninstalling it in My Computer but nothing is working for me.

Any ideas on how to fix this 

Thanks for the help 

First try every port–and no USB hubs, just direct connection to the computer.

If there’s still no love, go into Settings/System Settings on the Fuze and change the USB Mode to MSC and see if it charges.

Look in the computer and see what version of Windows Media Player it has. (Open WMP, click Help and About.)  It has to be 10 or 11 to recognize the Fuze in MTP mode, which is probably what you had it set to. Update Windows Media Player to 10 or 11, and you can switch it back to MTP.  

the whole system settings thing worked

I think maybe because my dads computer had vista and mine has the older windows 

Thanks, Black Rectangle, your advice - changing the USB Mode to MSC - worked perfectly for me.  Thanks so much.