Sansa Fuze isn't recognised by computer (but charges)

I had to do a hard reset on my Sanza Fuze because it wouldn’t boot up (by holding the power button on for 30 seconds) and it fixed that issue.  Now when I plug it into the computer it starts charging and says connected, but the computer doesn’t recognize it at all (I don’t even get the sound you get when you connect some type of USB device).  I tried using both USB modes, did the reset and format through the system menu. 

Since you have tried both modes, it might be a problem with the cord. The charging connection and the data connection are separate, and if the cord is wearing out you might be getting one without the other. You can get a generic one from Amazon or a cell-phone accessories seller for under $5. Just make sure it is for the Sansa Fuze or E200 (same cord) , not an iPod cord which will fry the Fuze.

I tried another Sansa e250 and it hooked up alright.

Try forcing the connection. With the Fuze turned off, slide the power switch down to Hold position (shows an orange dot).  Connect the USB cord to the computer, open Windows Explorer (Computer or My Computer). Hold down the << side of the wheel, and keep holding it as you connect the Fuze to the cord. See if it pops up in Windows Explorer.

This is supposedly  the equivalent of putting the Fuze into MSC mode when you can’t get to System Settings, but maybe it will awaken something. 

Otherwise, hate to say it, but the connecting port could be damaged.

Perhaps, maybe you could try hooking it up to another computer, just to make sure your computer isn’t the cause of the problem.

Tried it, it’s not.  I just bought the same mp3 player, hooked it up, and it works fine. 

Sounds like your problem is the port. And there’s not much you can do about that.