My computer stopped recognizing my Sansa Fuze


A few weeks ago, my computer (Windows 7 64bit) stopped recognizing my Sansa. It just doesn’t make any sign that it sees it plugged in. The Sansa turns on with the USB connection.

I took it to another computer and got the same result. I also tried a different cable.

I’ll appreciate any suggestions.


The cord has a power connection and a data connection. It sounds like the data connection isn’t being made.

Charge the Fuze up anyway since you can make that connection.

Then in Settings/System Settings/USB Mode change it to MSC mode. That’s the universal data connection. Auto Detect will choose MTP if it finds a current Windows Media Player in the computer–which it should on Win 7–but it’s quirky.  So see if MSC helps.

Otherwise  it’s either the cable or the connector in the unit.

If I were you I’d try one more cable, because if the problem is the connector, you’re going to have to replace the unit. 

Or, if you really want to keep using it, get a big MicroSD card and a card reader, and just drag-and-drop your music onto the card via the reader.

Possibly an issue here with the player? Have you tried considering a reset here?