My Sansa Fuze+ wont charge or even been recognized by PC

Hi, I have a Sansa Fuze+ for almost a year. Last week i used it as usual and when it battery died y plugged to the wall charger but it didn´t turn on. Then i tried with the PC but it didnt turn up or even was recognized as a usb device. I have tried every single step to reset the device to restore it to charge it everything but it doesnt work at all. I even tried to update the software but as the PC don´t recognize the device i cant updated it. Help me please, what could be happening to my MP3 how can i make it run and work. Help me please! Thank you very much.

Maybe your cord has broken. It happens.  You don’t have to get a SanDisk replacement–you can get a generic one at Amazon or at some cellphone accessory companies. The same cord works with the Sansa E200 so you could also search for that cord.

Your cord may be broken inside so no data or charge is getting through. 

Do you have another USB-to-microUSB cord, for a phone or a camera?  Or does a friend have one? (Android phone, Kindle, etc.) Try that.  It’s a standard cable so you can get any generic brand.

Same problem except mines charges in the wall.

Additionally, you can also use a tester on that cord and see if you really don’t have an output voltage on it. It wouldn’t hurt to be extra sure I think.

Having the same problem and have tried the same solutions.  My player will charge battery via the usb port but computer still will not recognize the player is connected!!!  Came searching for solution here on forums.  Help!!!  Why hasn’t anyone offered any solutions to this problem???  Have had my Sansa Fuze for about 1 1/2 yrs only used it to listen to music 4 or 5 times.  Have never dropped or exposed the player to extreem temps.  It’s kept on shelf in box so can’t be that it’s been broken or abused.  Decided to add more music but can’t  because computer won’t recognize the player.  Can’t even update it.  Finally purchased a SD card and loaded it and have my music back onto player but would like to load my music directly to player so can find my music files in folders or albums instead of all scrambled as individual files.  My player is out of warranty so can’t be replaced.  I have even purchased a new usb cord for the player but still having same problem. 

I just had the same problems with mine. Hoow I fixed it was I went into the settings icon, and worked my way to the reformatting in settings. I did the reformatting and now all is well. I did have to load up all the music that somehow was deleted. But, no more white screen, and the computer does find the sansa now. Back to normal.