Fuze not recognized by computer

Just got a Fuze to use Rhapsody, plug in to the computer and it’s not recognized

I’ve read a lot of posts and done the following: I have Windows Media Player 11, I ran the Firmware update, I downloaded the Windows MTP Kit, unisnstalled and reinstalled Rhapsody, uninstalled the Fuze on the device manager with the yellow error symbol several times and restarted a bunch

I plug in in MSC mode and the computer recognizes the new hardware, shows in Windows Explorer and Rhapsody, but I can’t authorize or load subscription files from Rhapsody, from what I understand b/c it has to be in MTP mode for this

I plug it in in MTP mode and computer recognizes new hardware and then in the New Hardware Wizard I get an error message that it can’t find the file to install the hardware

What do I do next?

Thanks

You have a choice of two separate modes to communicate with your Sansa, MSC (MAss Storage Class) where the player is seen as a flash drive, and MTP (Media Transfer Protocol) where it is seen as a media device, using the engine of Windows Media Player.

In MTP mode, many things are automated, as MTP is a virtual mode- the drivers are part of Windows Media Player.

Because of this, if you are in MTP mode, often that initial setup is confusing.  The drivers per se are actually part of WiMP 10 and 11.

Do you need MTP mode?  I see, in your case, you do, as you’re using Rhapsody.  MTP supports DRM licenses, needed for subscription media like Napster, Rhapsody, Audible books, NetLibrary, overdrive, and others.  It also automates many functions like album art, song ratings, and playlists.

MSC is preferred by many as it allows more direct control of the Sansa, and communication is easier.

As a test, on the Fuze, go to Settings > System Settings > USB Mode > MSC and plug in.  The Fuze should now be available if you open a Windows Explorer window (My Computer).

For MTP, manually select MTP Mode as you did here (unplug first, of course), then plug in.  Then open the Device Manager.  You can find this in many ways, via the Control Panel, or simply right click on My Computer, select Manage, then go to Device Manager.

The Sansa should be listed under Portable Device.  Double click on it, selecting the Driver tab, and uninstall it. (You can right-click to find uninstall as well).  Then, unplug the Sansa.  Plug in again after about 10 seconds, and the PC will reinstall the correct drivers automatically.  I prefer to reboot the PC prior to plugging in, as Windows can be lazy when it comes to repairing those registry entries following the uninstall.

Bob  :smileyvery-happy:

The computer recognized MSC mode, but I can’t do anything with that since I want to put Rhapsody subscription songs on the Fuze.

I have gone in to the Device Manager and unistalled the Sansa a couple times, rebooted and plugged in again, in MTP mode. The computer rcognizes new hardware. Then the New hardware Wizard pops up, asks me if I want to use Windows to install the new Hardware, I say yes, it shows MTP Device and it looks like one folder transferring files to another and then I get the Error message that the files could not be found and the hardware may not be installed correctly. Should I un-install the Media Player again and re-install that? Like I said I upgraded to version 11 and downloaded the MTP Kit from Windows as well, before attempting to plug in the Fuze.

You’re on the right track.  The drivers are part of WiMP 10 / 11.  Two other issues come to mind.  Many users found that the PS3 drivers, if you have them, interfere with MTP.

Additionally, try this, from the command prompt.

Bob  :smileyvery-happy:

I have a similar problem. I tried to uninstall the drivers thru the device manager, but my player, when set in MTP mode, isn’t even recognized in device manager. Nor is it recognized by my Napster service. This player worked fine, until recently, with Napster, so I’m not sure what has happened. Any ideas what I can try?

Tad 

I see this thread has been dormant for a while!  First switch to MSC mode on the player (settings > system settings > MSC , and plug in.  Open a Windows Explorer window (My Computer) and see if the Fuze shows up as two drives.

This verifies that the device,scable and USB interface are working.

Then unplug the device and select MTP mode.  Plug in again.

With the same Windows Explorer window, the Fuze should show up as a portable device without a drive letter assigned to it.

Open Windows Media Player and see if it communicates with the Sansa.

If not, FIRST verify that you have Windows Media Player 10 or later via Help  > About from the main drop down tree. If not, go to Check For Updates.  Upgrade your media player to at least WiMP10, which has MTP support.

When upgrading, disconnect the Sansa until the update is complete, and restart your PC.

After all is done, plug in the device and see if it communicates in MTP mode.  If not , don’t worry, right-click on My Computer abd select the Device Manager function.

You should see the Sansa under Portable Device, quite possibly with an orange warning triangle.  Double click or right click on it and select uninstall.  Disconnect, wait at least 10 seconds, or reboot.  Then try plugging in again.  You will be greeted with a few pop up messages, New Device Found and MTP device.

If successful, you will have Napster or Rhapsody MTP capability.

Bob  :smileyvery-happy: