Fuze won't install properly

Trying to install my Fuze on a new PC with XP. Windows detects it and installs but then returns an error that it did not install properly.  I’m in USB AUTO mode. 

If I use MSC mode, then Rhapsody doesn’t let me xfer tracks to the sansa.

How do I get the fuze to install properly?
I disabled the fuze from device manager and reinstalled but receive the same issue.


If the PC is new, your Windows Media Player will most likely be version 9, which does not support MTP mode.  Open Windows Media Player, and click on Help > Check For Updates.  Update the Media Player.

For troubleshooting MTP, manually set this mode on the device via Settings > System Settings > USB Mode > MTP, then plug in.  For Rhapsody, you’ll need MTP for the To Go service (secure WMA).

Open a Windows Explorer window by going to My Computer, and see if the Sansa lists as a media device (MTP active).  It needs to appear under “other”.  You should see a little Fuze icon.  The drivers for MTP are part of WMP10 / 11.

If the Fuze does not display, open the Device Manager via Control Panel > System > Hardware tab > Device Manager.  Look for a yellow trouble triangle.  The trick is to uninstall (don’t “disable” ) the device, then unplug.  When you plug in again, you should be greeted with the “found new device” message, and Widows will reinstall the correct drivers.


Message Edited by microsansa on 04-03-2009 06:23 AM