Vista not recognizing Fuze

So I just picked one of these little guys up today, and when I got home, eager to put my music on it, Windows Vista decides that it doesn’t like it, and will not under any circumstances allow me to use it.

I’ve been searching on google for hours, and so far i’ve gotten nowhere, and discovered nothing except that my other Windows XP computer detects the Fuze and is all buddy-buddy with it.  Unfortunately, all my music is on the Vista machine.

I’ve tried nearly everything anyone has suggested on the internet, everything from modifying the registry, to leaving my computer unplugged for 30 minutes, and nothing at all has worked.

So now I turn to the community, if anyone has any suggestions as to how to make this little guy go, i’d be extremely thankful.

Just to clarify, here’s a list of things I have tried:

Rebooting (obviously)

Using a different USB port

Updating USB drivers

Unplugging the computer

Registry modifications

Different USB modes on the Fuze

The exact message that Vista is giving me is that obnoxious little bubble on the taskbar that says “USB device not recognized” and it claims that it’s malfunctioned.  Also, this is on Windows Vista Ultimate, with the latest (as far as I know) updates.

Message Edited by Krizkor on 07-08-2008 06:24 PM

One thing I see that is not on your list is to check Device manager for error when the Fuze is connected.

You might also want to check out this webpage;

FIX: Windows Media Player cannot synchronize media to an MTP-capable device on a Windows-Vista based computer
Message Edited by Tweet on 07-09-2008 12:40 AM

You’ll find that Microsoft engineered a real hairball with the MTP / Vista / Windows Media Player 10/11 upgrades.

Try the Fuze’s MSC mode option to verify that the USB port is happy with the device:

On the Fuze, select Settings > System Settings > USB Mode > MSC and connect your new Fuze.

On the PC, open a Windows Explorer window (Vista calls it “Computer” I believe.).

Does the Fuze appear as two successive “devices with removable storage”?  The first alphabetic listing is the Sansa, and the second is the µSD expansion slot.

If everything is OK at this point, it’s all a matter of making the MTP protocol on the PC happy.  There’s plenty of information here on the forum under keys like “Code 10” and “MTP Porting kit”, plus the link in the previous post.

You can improvise and drag/drop music into the “Music” folder, while in MSC mode. 

I recommend MTP for the Fuze since with WiMP11, the album art is automatic, plus you have ready access to subscription services. 

Bob   :smileyvery-happy:

I have the exact same problem, works on windows xp for me… but when using vista ultimate with all the updates its not working. Vista keeps wanting to install a driver which to my knowledge does not exist for a sansa fuze 8gb. everytime i plug in the usb, regardless of which one, it looks for a driver to install… i have installed the mtp executable file with no luck.  I havent tried the registry hack but have no clue on how to do it either…anyone have a clue on whats going on???

Have you tried to Uninstall within the Device Manager while your device is plugged in? 

Plug in player

Open Device Manager

Uninstall MTP device

Unplug from computer


Plug device back in

Good luck.

I have 3 of these Fuze devices - 2,4, and 8 Gb models. Great for the price. Mine all worked fine for months until I attached another MCS MTP type media device (in this case ah the evil Microsoft Zune) for comparisions and the Zune worked ok, but it hammered all my Fuze drivers since they all seem to fight over the same USB ports and devices like the Zune from Microsoft think it’s KING.

Hmmm … Microsoft Vista … Microsoft Zune … SanDisk Fuze … gee I wonder which device will win the USB tug-of-war?  Trust me - My Sansa Fuze from SanDisk is a great media device and the best for the money (with a micro SSD slot for up to 32Gb) all for as little as $39.00 US   ah but I digress …  Here’s how to get the Fuze to connect to Vista :  As earlier in this news thread, go to device manager and uninstall all the USB drivers for composite,mass storage, and generic USB controllers. THEN when you reconnect your Fuze it will re-install all the right drivers for USB in the right order and the mis-behaving USB (in my case the Zune) will be kicked to the curb.  Now go to Vista Start Computer and you’ll see the Fuze has appeared, and the device will connect and allow transfers. Whalla !   Music, Video, and Picture Nirvana has now returned to your PC world!

You’re welcome.  Don’t blame SanDisk. Blame Microsoft and that giant sucking sound of money being transfered from your wallet to Redmond WA