Fuze with Vista

Hi all,

My delima; I got a nice, brand new 8GB Fuze for Christmas, which is just great. However, my computer is running windows vista os and doesn’t see or respond in any way when I plug the Fuze in to the usb port. I have already tried a multitude of posible fixes, but to no avail. When I tried to do the (sugested by sansa) hotfix-KB940199, I got a message telling me that it didn’t apply to my machine. I’m just a little frustraited with it. I (fortunately) still have an older machine that has XP pro on it and the Fuze works just fine with. However, I’m trying to retire the old machine.

Does anyone know how I can get my Vista machine to see the FUZE??? Any help would be greatly appreciated.


That is a interesting situation. I can play Sansa on Both of my Vista home machine and XP home machine.

First, try to update your machine: www.windowsupdate.com

Second, play with USB option of your sansa: Auto, MTP and MSC to see which one works.

Are you plugging directly into the computer or to a hub. I purchased 3 4gb Fuze for Christmas. (daugher, granddaughter and myself) One worked with the hub no problem, the other two were not seen when plugged in the usb hub. But when I plugged them into the computer directly showed up and worked no problem. (Vista laptop) Now I just need to figure out how to do the firmware update on mine. Other two worked flawlessly.

Good Luck

Did you try this?


Perhaps there is a problem with the MTP drivers on your pc? Did you try setting the player’s USB mode to MSC then connecting? Are you logged into Windows as administrator? Did you check your Windows permissions?

Are you using a rear USB port? Is the player’s cable plugged directly into the USB port, and not into a hub or USB extension cable?

Message Edited by JK98 on 12-26-2008 12:00 PM

I’m plugging directly into the computer, I haven’t tried changing the usb options yet though. I’ve already went to windows and downloaded everything that could be related. I guess I’ll keep trying stuff till something works.


Thanks for the help, it’s working on vista and XP, I did everything sugested so I’m not exactly sure which one did the trick, but I am thankful for the help:smileyvery-happy: