PC Won't Recognize Fuze

I recieved my Sansa Fuze for christmas and it has been working fine up until I upgraded the firmware version. Now when I try to connect my Fuze to my Vista PC it doesn’t work, I have looked around and tried uninstalling drivers, switching USB modes, switching USB ports and anything else I could find and it won’t pop up in My Computer at all. in the Device Manager it has the yellow warning symbol and it gives me a “This device cannot start. (Code 10)” error in the properties. anyone know how to fix this?

Its your Drivers. They are not allowing Windows to start your fuze. If you have a disk with your USB Drivers (From when you Got your PC) use it to roll the drivers back, If not then go to system restore and roll your PC back to before you re did the drivers and See if that helps. What version of Vista? Service Pack?

Windows Home Basic Service Pack 1 is what I have. And rolling my PC back would erase everything I have done up until now, stuff I’ve installed and downloaded would it not?

No it would not. I have another thought before that however. Try resetting your fuze. Push the power button UP and hold it for 15-20 seconds. This Just returns the fuze to its default. If you do roll your computer back it wont delete files, like downloads, It will reset your Computer to the previous state. You may lose some progams as well.

i tried it and it didn’t work, I also tried it again but I uninstalled the driver and reconnected it and it was working for a few seconds then it stopped.

Message Edited by XCrownedClownX on 01-07-2009 08:10 PM

Ok… Youb are the one of 2 people having the exact same issue right now. Check out this thread Pay attention to Message 19 (Nutron Bob) thru the end of the thread, and you can ignore the stuff that doesnt apply to vista.

I did what it said in post 19 and it connected as SANSA FUZE (J:). after that I switched it over to the MSC mode and it connects as SANSA FUZE (J:). I don’t know why it won’t connect in the other mode and show the Fuze icon at the bottom under ‘other’. Since this works should I format my Fuze to clear the music off the MTP mode and copy it over to the MSC mode? or is there some way now to get the MTP mode working again?

Ok So it connects in MSC but not MTP. GOOD! Now we can make some progress… Let it charge a bit. Do you know what firmwire you are running? I know you said you upgraded but to what exactly? Try reinstalling the Firmwire.

Its at 100% charge currently. oddly it would charge but not connect in MTP mode. I am on firmware V01.01.22A. and how would I reinstall the firmware exactly?

@xcrownedclownx wrote:
Its at 100% charge currently. oddly it would charge but not connect in MTP mode. I am on firmware V01.01.22A. and how would I reinstall the firmware exactly?

How id I know you would ask that and I would blank on how… Ill look it up and let you know.

As far as I know the reinstall the same firmware onto a device you would first have to downgrade it which isn’t possible with the Sansa Fuze… as far as I know. I do know that you can’t install the same firmware ontop of the same firmware. I’ve done alot of stuff with firmware on my Playstation Portable so I’m quite knowledgeable in those areas.

One thing I failed to do though is go to the support section of the sansa site and try stuff there so I’m installing hotfixes and whatnot currently

Edit: None of the stuff in the Fuze FAQ worked :cry: 

Message Edited by XCrownedClownX on 01-07-2009 09:03 PM

The only way I can remember to re do your firm wire is this… Open your Fuze thru My Computer, Copy all your files to you PC. Unplug the fuze, go to Settings > System settings and then choose format, It will delete every thing on your fuze, then you can re install the firmwire using the Firmwire updater… I dont know if this is something you would want to try or not but thats what I remember.

Dont Format with Windows tho.

Message Edited by Conversionbox on 01-08-2009 12:15 AM

I tried it and it didn’t work. probably because formatting the Fuze just wipes everything off the internal memory, doesn’t clear the firmware to the original given with the player. Oh well, thanks for the help anyways :smiley: at least I can transfer stuff to and from my Fuze again.

I PM’d BOB and Marvin Martian about how to do the firmwire thing maybe they have an Idea… I get stuck on it works with one mode and not the other.

what I don’t get is why it worked with the older firmwaree but not the new one. I also hooked my Fuze up to my mom’s laptop and it installed and worked perfectly fine in both modes so it’s probably something to do with the drivers.

That link does not work on the “Check out this thread” I am having the excat same problems. Sometimes it connects to my PC sometimes it don’t, an right now it’s not doing anything. I’ve downloaded ALL the softwares that would possibly work, I set the settings on MSC. Please help me…

Your cord may be breaking. It’s probably worth spending a few dollars to try a generic replacement cable. 


To get firmware, go to the sticky firmware post above and click the Manual Firmware/ All Regions links. It helps to know whether your hardware is version 1 or 2–look at  Settings/info/System info to see whether your firmware starts with 1. or 2.  2 is a different hardware from 1–it is not an upgrade.


If you want really older firmware, try experimenting a bit. Get the link for the current firmware and change the version number (at the end) to lower numbers.  For instance, the current link is http://mp3support.sandisk.com/firmware/fuze/fuze01.02.31.zip

So change the end of the link–1.02.31.zip–to 1.02.28.zip, or 1.02.24.zip , or  lower, etc. Some of those numbers lead to old versions, some don’t.

And yes, you can downgrade. Get the older firmware, unzip it and drag the file onto the disk drive that says SANSA FUZE.