Video playback not working after version 4.3.0 update

Yesterday: loaded some .mp4 videos onto the iXpand, they played as expected (iOS 10).

Today: updated iOS app to the new version 4.3.0, videos not longer play.  Restarted app, ejected iXpand, no luck.

The videos are listed as expected, you can open the video, but the video never begins playing.  There is no time information for the video,  just --:–.  Waited, video never starts.

Seems like the app update borked the video playback.  For me.

What iOS device do you have? I tried on iPhone 7 and MP4 seems to work. I do have 2 MP4 files the sound is choppy in but other work. Can you PM me a link to one of your MP4 files that does not play? 

It is a 12.9" iPad Pro. 

I can’t easily put the files anywhere (it’s 4GB or something like that).  Of note, same file worked before the update.

I’ll get some details about the file.

Details will definitely help but if you can get me a sample file it may be faster to report. Do you have dropbox? If so you can send me a link and I will get the file to sandisk support and they can file a bug report.