MP4 movies

I have 6 MP4 movies on my ixpand but when I play them they stop/freeze after < 1 minute. I’ve tried all 6 and have the same issue when using my ipad

Movies work fine when the ixpand is inserted in the PC

what codec is used in the MP4 container? Also sandisk has a dedicated video palyback app called TopReel. have you tried playing the videos in that app?

Here’s what I did to fix it:

First, make sure you have enough space on your iPad for the movies to play smoothly.

Try updating the iXpand firmware and also check for any iPad software updates.

If the issue persists, consider converting the MP4 movies to a slightly lower resolution. Sometimes that helps with playback glitches.

Also, check if there’s any specific app on your iPad causing the problem. Try playing the movies with a different video player app.
Also, you can try downloading the video at and play it there. Good luck!

Here are some possible solutions to the issue you are having with your iXpand:

  1. Check the compatibility of the videos with your iPad. Make sure that the videos are in a format that your iPad can play. You can check the compatibility of the videos by going to Settings > General > About > Video Playback.
  2. Try transcoding the videos. Transcoding is the process of converting a video from one format to another. This can sometimes fix compatibility issues. You can use free transcoding software like HandBrake to convert the videos to a format that is compatible with your iPad.
  3. Try formatting the iXpand. Formatting the iXpand will erase all of the data on it, but it can sometimes fix compatibility issues. To format the iXpand, connect it to your computer and open Disk Utility. Select the iXpand and click on the Erase button.
  4. Contact SanDisk support. If you have tried all of the above and you are still having problems, you can contact SanDisk support for help. They may be able to help you troubleshoot the issue or replace the iXpand.

I hope it helps!