USB Flash not recognised

Hi, I have an iMac and have used my CruzerForce 32GB on it many times to store files.  Tonight for the first time when using it I received the following message:

“This version of SanDisk SecureAccess V2.0 requires a SanDiskUSB Flash Drive.  Please insert one and try again”.

Needless to say it is connected and recognised on the desk top and under utilities.  I can see that the has 20.3MB so assume that my files remain, however I am slightly flapping because I need to open them asap and can’t do so!

Please help, I’d appreciate any advice.  Thank you.



as far as i know there is an issue with secure access along with the newer El capitan OS. so in that case i suggest using the secure access software with a windows pc or a previous mac version like the yosemite to access your data and have a backup of it.

when the update will be released then you will be able to use the software with the el capitan normally. 


Thank you very much for your very helpful reply.  My OS version includes the latest update and it certainly worked before, so I will see what happens after the next OS update.


SecureAccess version 3 resolves the issue with El Capitan IIRC. You will need to get to a windows or older version of Mac OSX and decrypt you files. Then update to SA v3 and reencrypt the file. After the update it should work with El Capitan. 

1 Like


My problem has not been resolved and I really need to access the files.  I tried a PC but that did not work and yesterday I installed the latest El Capitan update however the same error message came up.  I dont know anyone who uses an older version of MacOSX to borrow.

I also note that to switch to V3 I need to access the disk to get started, so I appear to be in a catch 22 which is proving to be a real issue.

Please can anyone Help!!

Thank you.