This application is only runs on a SanDisk flash drive

macOS 12.0.1 - Monterey
SanDisk Cruzer Glide 128Gb

I am unable to open the SecureAcess app: After upgrading to Monterey, when trying to start SanDisk SecureAcess v3 app, I receive the following message: “This application only runs on a SanDisk flash drive.”

The drive mounts and is shown on the desktop when inserted. If I look at the contents in Finder everything (directories/files) is there as is all my data (except, obviously I cannot access it). Is there an upgrade or firmware update that I need to install/apply? If so, where do I find it?

Thanks.

1 Like

Hi. Have you heard any word from SanDisk about fixing the problem with opening SecureAccess after the Monterey on OS installation?

Hallo

Not a word.

Monterey has been out one month and available to developers for almost one year. This should never have happened. I am extremely annoyed with them, I just do not know how to escalate this with them. It seems from the different SanDisk forums I have been on that this problem/lack of solution is not surprising.

I will let you know when/if they resolve this.

I have the same problem. The Secure Access still works fine on the Big Sur (I tried on a Mac where the Monterey is still to be installed).
Other companies have already provided apps updated for the Monterey, see, for example Onyx.

So when is this going to be fixed? Luckily I only broke it on my test/dev Mac. I have a 128GB, 64GB, and numerous other SANDISKs I have purchased over the years. You need to fix this!

I’ve just downloaded SecureAccess software but it doesn’t run because of ‘Monterey’ on my macbook, as I understand now.
Let me know when there is a solution.

We have all been waiting for months. SanDisk does not appear to be interested in fixing this issue. Rather, many, many of us have encrypted SanDisk drives that have become worthless.
Capitalism at its best.

Very disrespectful to their customers.

Je suis d’accord.

Having lots of SanDisk flash drives, today I tried to install and use SanDiskSecureAccessV3_mac.app and got the same message after installing the program. "This application only runs on a SanDisk flash drive.”

At least 10 flashdrives from 32 to 256 GB all came with the software and the voucher for a free download and 1 Year description for RescuePRO. Non will accept the new app on my Mac.

I will test it later on an older version OS and tell if it works after that. (not sure when)

Not sure if this can help you, but when you have the possibility to use a Mac with any older version off macOS you could install the newer version 3.02 from SecureAccess on your flash drive(s) and then they will work on Monterey as well.
I did so with several flash drives from 32 to 253 GB and they all work well since.