application only works on a sandisk drive?

trying to run sandisk secure access 3, and it’s saying it only works on a sandisk drive. I am using a sandisk drive. so whats going on?

Do you have SecureAccess on the SanDisk drive?  If not, that’s the problem.  It will only run from there.  If yes, I suspect your SanDisk drive is a counterfeit.

yes i installed it on the drive. its a sandisk cruzer 8gb. pretty sure its not a fake I remember buying it.

I have the same problem.  Brand new iXpand 32GB.  When I run SanDiskSecureAccessV3_mac.app on the drive I get error “This application only runs on a SanDisk flash drive” .  Help please.

Return it to the seller.  IMO It is either counterfeit, used or broken.

This happened to me with an authentic registered product purchased from WalMart. Here’s what I had to do:

  1. Go to Sandisk website and download the current application file. (You already did that if you’re asking this question.)

  2. Go to the download folder on my computer. 

  3. Move the downloaded file from the download folder to the sandisk product folder.

  4. Open the application from the Sandisk product folder. 

It worked perfectly once I put it in there and opened from the flash drive folder.