SecureAccess 3.0 not working on Mac/El Capitan


After upgrading to El Capitan on my Mac, I could no longer access the Vault (SecureAccess V2) on my SanDisk Ultra USB drive. I had no problems on Windows 7. However, I migrated to the Windows version of SecureAccess 3.0 as per your instructions over here, which worked fine.

But I am still having problems after migrating to SecureAccess 3.0 on my Mac. The package installed successfully, but when I click on the application “”, I keep getting the following message: “This application only runs on a SanDisk flash drive”.

I have deleted everything, including the Windows version of your software. I have reformatted the drive with Mac’s DiskUtility. I have reinstalled and deleted and reinstalled SecureAccess 3.0 several times, and I keep getting that message.

I can transfer files to the USB drive normally - but I cannot run the Vault. This is most annoying. One of the things I like about SecureAccess is that I can switch between Mac and Windows. Now I can’t use it at all on my Mac.

Is there still an issue between the latest version of SecureAccess 3.0 and El Capitan?

I have the same problem. Though I can use SecureAccess v.3 on my  flash drive on my wife’s laptop running OSX 10.10,  I cannot access the vault on my laptop running OXX 10.11.  I get the same message as you.  Clearly the issue is one of compatibility!

Hi vtinto,

I updated to El Capitan 10.11.1 yesterday and SecureAccess v3 for Mac is working again. Hope this works for you, too - please post back if it does, and then I can mark this thread as solved :smiley:

Hi All,

I’ve upgraded to Mac/El Capitan, now I’m having a problem with SanDiskCruzer Glide 128gb a dialogue box pops up when I launch  SanDiskSecureAccessV2_mac " This version of SanDiskSecureAccessV2 requires a San Disk USB Flash Drive. Please insert one & try again". It was fine before the upgrade.

I really hope I can retrieve the data as it is a lot of precious photos of family who have passed away.

Any ideas folks ???

Thank You.

Hi LL,

You’ll have to upgrade to SecureAccess V3 and by all means also make sure you install the latest update for El Capitan (El Capitan 10.11.1) - it was released only a day or two ago to correct some issues in El Capitan.

In order to upgrade to SecureAccess V3, you’ll have to save your vault. Which is a dilemma, because without logging in you can’t save your vault.

What I did was insert my USB drive into a Windows computer (there should be a file called "SanDisk SecureAccessV2_win.exe on your flash drive which will allow yout to access your vault on Windows). On Windows, log into SecureAccess and save your vault/files to another usb drive or hard drive. By all means do this, since upgrading to SecureAccess V3 means that you have to delete your vault…

Then, on your Mac, download SecureAccess V3 for Mac over here (you’ll find the download links under the header “Download SecureAccess (for Cruzer flash drives)”:

You can also upgrade your SecureAccess software for Windows, too, but version 2 worked fine on Windows 7 for me.

Once you have downloaded SecureAccess V3 for Mac, follow the instructions over here:

Hope this works for you like it did for me :slight_smile:

Brilliant ! Many thanks Athene :smiley: I will try that this weekend & let you know how I get on.

Hope it works, and looking forward to your update  :smiley:

I’m having the same issue, running El Capitan 10.11.1.

When I open SecureAccess 3.0 I get a message window that says, “This application only runs on SanDish flash drive.”

I’m not worried worried about recovering my old vault as that’s all backed up, I would just like to be able to use my existing one with the SecureAccess software!

Thanks in advance for any assistance.

Hi theomiz3,

Before upgrading to SecureAccess 3.0, did you delete everything from your usb drive? Because first I backed up my vault via Windows 7, then removed every single file off the drive, and then installed SecureAccess 3.0 (for Mac and Windows).

I put the usb stick in my Mac tonight and as soon as I opened SecureAccess 3.0 it started running an update. One of the items it says it fixed is compatiability with El Capitan.

So, I’m all good now, thanks!

1 Like

Thanks for the update, theomiz3 - marking your post as the solution :slight_smile:

Unfortunately, the compatibility problem/error message persists with my Extreme 64Gb, Mac OS 10.11.1 and Secure Access 3 version 6.0.17.

I updated El Capitan 10.11.6 and I still cannot install scandisk access on my Mac hard disk