SecureAccess 2.0 and El Capitan

Hi all,

I recently upgraded from Yosemite to El Capitan, when I tried to launch SecureAccess 2.0; I’ve got an error message that says ‘This version of Sandisk secureacess 2.0 requires a SanDisk USB Flash Drive’. I find it weird because I am using the same sandisk drive, only difference is I’m running El Capitan now.

Any ideas how to solve this problem?

Much appreciated


I am having the same problem. I have two USB SANDISK ULTRA USB 3.0 FLASH DRIVE, one running V2 and the other V3. I have tried them on mutliple computers all running El Capitan and I get the same problem on all.


i’m very tempted to downgrade back to yosemite to see if it works

I have tried to downgrade to Yosemite, since I installed IOS9 that is impossible, well almost and not worth the effort

I have exactley the same problem. Did you get any helpful answers yet? would be much appreciated here too.

I have had no answers as of yet. I emailed Sandisk ut they have not got back to me. I have searched the web extensively and cannot find anyone with similar problems just now, so here is hoping someone picks up this thread or Sandisk answer. I do not have access to any other IT system so it is frustrating

I don´t know if it is a problem of ScanDisk or a problem of Apple - let us hope they answer soon…


I have tried downgrading back to Yosemite and it works. I’m suspecting might be apple’s problem

How did you manage to downgrade to Yosemite. It seems a devils own job

Is actually not that bad if you have been using Time Machine as backup. Before upgrading, I made one last backup with Yosemite. To downgrade, backup one more time just in case, I also made a copy of all my important files on my external HDD, just restart your Mac and go into recovery mode, choose restore with time machine backup and click on the last backup with Yosemite. All went smoothly for me. I read the instructions through here

Still we need a solution for El Capitan!

I have made contact with Sandisk and sent them the screenshot of the problem and await a response. 

I also spoke with Apple and they could not assist, saying it is a Sandisk issue

Once I know I will post the result on this site

Thanks for that…looking forward to further news…it is really a problem…

Not a problem. 

I received this earlier today and once they let me know I will post it

We have escalated your case for review by an L2 Technician. We will provide a response to you shortly.

Thank you,

SanDisk Global Customer Care

Hi, just received this from Sandisk;


Thank you for your kind update.

We would like to inform you that SanDisk has identified a problem running SecureAccess on the new Mac OS X 10.11 (El Capitan). The issue has been reproduced and reported to our development team. We are working on resolving the problem and hope to resolve this quickly. We will provide notice to you when we have an update available. We apologize for any inconvenience due to this problem. 

We remain at your service for any additional information or assistance.

Best regards,

Sally H.
SanDisk Global Customer Care


Any news about this issue. I have to use the files in the vault folder urgently and I ma getti g really worried  they may have disspeeared, Do you have any progress updates since Monday? 

Thnaks for your help 


Thank you very much for your update.

The update for El Capitan is now available. You need to download the latest version of SecureAccess to resolve the issue with El Capitan.

This version works on El Captain.

Please make a backup of the vault before proceeding.

Download the application directly to the drive and double click to unpack and run it.

You should have access to the vault again.

Thank you for your kind cooperation and for allowing us to be of service to you!

Best regards,

Elif C.
SanDisk Global Customer Care

I have already installed the El Capitan and did not back up the vault before because there was no way of knowing that the problem occurred . Now the program does not open for the backup to be done before installing SecureAccess 3. And now ?

Same here. I requested help and got the reply below, which is not helpful becasue if I had another Computer with the old operating system to do the backup I wouldn’t have contacted them in the first place. What I think we all need is to be able to acces Vault 2.0 in OS El Capitan

Dear Ignacio,
I would like to inform you that you can download SecureAccess V3.0 in order to be able to use it with your operating system El Capitan.
In order to be able to use our software please follow the steps provided bellow:
-I would advise you to make a backup of your vault files, try to use SecureAccess from another OS and save your files there.
-Download the application directly to the drive (you can download the software from the link bellow)
-Double click in order to unpack and run it
I attach the following links for more information:
After that you should be able to use SecureAccess V.3 and access to the vault
Click here to register your product online.
If you have any other consult please let us know.
We thank you for contacting us and we wish you to have a great day.

Best regards,

Sarah K.
SanDisk Global Customer Care
I recently upgraded from Yosemite to El Capitan, when I tried to launch SecureAccess 2.0; I've got an error message that says 'This version of Sandisk secureacess 2.0 requires a SanDisk USB Flash Drive'. 

Any ideas how to solve this problem?

Much appreciated

Problem solved :smileyvery-happy:

Thanks to all of you, especially dicook!


Can you explain please if the V3.0 allowed you to see the files that were originally in the vault in V3.0? Did you back them up first?or just by installing the newer version they became available? Please elaborate.