Unusual Connection problem

I have a problem with my 2g v01.01.29A Clip not being recognized by either PC or OSX with 3 different usb cables.

It powers up and runs normally… except that when it is plugged in it (turns on like you slid the power switch) it appears to be charging (battery icon flashing, but it actually behaves as if turned on… ie the radio plays and likely the mp3’s would too except that they are now deleted after I reformatted it in attempt to get this be recognized by my computers.

I have tried all 3 usb settings Auto, MTP and MSC plus the forced MSC via moving the power to the locked position, then keeping the center button held down while plugging in the USB cable.

I have tried to reset it. By sliding and holding the power up button for 15+ seconds (it just turns on and then immediately turns off long before the 15 seconds are up) Holding it up for a whole minute doesn’t do anything more…

I have done the *reset all* via it own settings menu.

I have *formatted* it via its own settings menu (erased all the current files)

I have another clip (same rev and model) that works fine with my 3 usb cables and my mac and PC I tried to get this one working with.

I checked the usb socket of the clip with a magnifer and it looked clean. But used some contact cleaner anyway.

Does anybody have any other suggestions?  

This one is my wife’s and I am losing face because I told her how great the clip was…

It seems the next step is to take it apart and see if there is internal loose connections at the usb socket. But what is strange is it turns on by itself when plugged into a computer’s usb port…

 thanks Alan

Seems like the player still receives power but has lost its USB data connection (it behaves the same way when connected to an external USB power supply). Could be a bad solder joint indeed. With some bad luck the USB interface might be shot, but I’d put my bets on a soldering problem.

BTW, why are you still on .29?

As a test to confirm what Keb_gr stated, I plugged it into a small usb charger…

What happened seems pretty odd. It said “connected -> writing” just like it was suppose to

when attached to the computer. However, the caveats are:

  1. This charger and another one I tried before did not have enough mAs to actually charge the battery.

They both have one of those charging Leds that could be part of a sensing circuit that fools the clip into thinking it is

connected to a computer?

  1. My other clip connected to the same chargers does the same thing and it is running v01.01.32. 

* I found out about this recognition problem when I got it from my wife to update to rev32. (she had some connection problems in the past but the forced MSC mode by locking and holding the center button down always worked)

Any other suggestions before prying it apart to check out the usb socket soldering? and thanks