Weird Power Problems - Turns on/off repeatedly when usb connected, won't power on

4gb Clip, about 3 months old. I used it until the battery was completely drained.

Here are my weird symptoms:

  1. Can’t power it on

  2. Soft reset (hold power for 15 sec) does nothing

  3. When connected to usb cable, after about 20-30 seconds it repeatedly does this:

  a) Turns on

  b) I get the “usb device connected” sound from XP

  c) XP tells me the device is not recognized

  d) The clip shows “Writing”, then quickly “connected” and then shuts off

  e) Immediate restart of the Clip, repeat above steps

Oddly, when I first connect the usb cable nothing happens, but if I disconnect it, it immediately turns on (then turns off).

I am leaving it connected to usb right now, letting it turn on and off repeatedly. It looks like it may actually be taking a bit of a charge, so maybe the problems will go away?

Oh, and I did try the Power hold-center button-connect usb trick. No change.

Matt Kruse

Exact same problem for me. 1GB purchased in Nov 07. In Aug 08 problems started occurring just as described above. Rolled back to the oldest firmware I could find - no change. Then loaded all the subsequent firmware versions. No effect. Any help?

BTW, I just gave up and bought another 1GB clip but would like to resurrect the old one.

How did you get the new firmward on the clip if you couldn’t get it connected to your computer? Mine connects then disconnects so fast that it never shows up on the computer for me to apply firmware to.

If you drained the battery completely… then  you might want to try to charge until it gets back to live… that would mean leaving the clip charging for an entire day or even more…

 

If the battery reached bottom… then its probably dead… but there is a chance of getting it back to live…

 

If thats not the problem well… sorry… call sandisk

Matt, about 1 in 5 connections allows me just enough time to put the firmware on the player. Very frustrating but I got’er done.

robjose

Yep … I went thru all of that after about 28 days of ownership of my 2Mb Clip … basically it was haunted … turn on turn off … do that for a while … quit … do it later … as I said haunted … I took it back to Best Buy and got a replacement … so far … (less than 30 days at this point) … not haunted yet …

Get it replaced …  

Try different USB cables as sometimes the cable is the culprit in this situation!!

You might also want to try different USB ports (with different USB cables) on your computer.

Finally, make sure you connect in MSC mode by: putting the Clip in Hold (orange showing on power switch), press & hold the center button while you plug in the Cip to your computer, and continue to hold the center button until the Clip is recognized by your computer.

Let us know if this works.

I have tried 3 different cables on 3 different computers. No difference.

I have tried the MSC mode thing. How long do you typically have to hold it? I gave up after about 2-3 minutes.

Incidentally, I did leave it plugged in overnight and although it kept connecting then disconnecting, it did seem to charge. Maybe I’ll try all these steps again now that it seems to have about 3/4 of a charge.

MSC should kick in, in 10-15 seconds (hold switch on and pressing the Clip’s center button down). 

I would put myself out of my misery and call SanDisk for a warranty replacement …  (Sorry.)

I have had the exact same problem with 2 Sansa Clips. One is a 1 GB I got a while ago. It worked fine for a while but recently did this. I ended up buying another 2GB clip, and this happened after 1 day!

I assume it MUST be due to some kind of compatability problem with my computer? I have tried plugging the 2GB into another computer though and get nothing - no charge light anymore nothing. (I sometimes got the on and off problems - that was the first sign. This ran the battery down too).

Does anyone have any solution to this yet? Any way of restoring a ‘dead’ clip?  I have 2 now! (I will probably just return the brand new 2GB one!)

 Thanks

-Justin

Some Clips have had battery problems–do not hesitate to return and replace a problematic Clip, or to contact SanDisk for a warranty replacement.

Well, this appears to be my problem as well.  I have had 3 2gb Clip’s for almost a year now.  All have old firmware; they have always worked fine until now.  1 still works fine, the other 2 are not recognized by my computer anymore.  The batteries seem fine.  I run Windows XPsp2 with Media 11.  Windows recognizes the USB connection long enough to no longer recognize it…like 1/2 a second.  Thus I cannot update the firmware. I have reformatted and nothing changed. 

Tried connecting with the device off, the “hold” on, and holding down the middle button

Reformatted the device

Updated my Windows Media Player to version 11

Downloaded Windows MTP Porting Kit

Downloaded the latest update from Sansa (which I can’t get onto my Clip because the computer won’t recognize it)

I also tried to put the device into MSC mode before connecting, but have no USB option in settings

Any more ideas?

Message Edited by tnegiet on 09-25-2008 02:48 AM

Wholly Crap!

After all that, I read in another post it might be the USB cord…having two cords already connected I thought that was not my problem, but I figured that I had tried everything else why not eliminate that as well.  So I disconnect the Clip and short cord I had attached on my USB Hub, and plugged it into the ultra inconvenient USB port on the front of my computer.  In order to see it, I have to turn my office light on and not only does it connect up just fine but I also notice that the power cord (Not the USB cord) to my USB Hub is disconnected!  And guess what…that one works fine now too! 

I’m now wondering if all the poor souls that are having connection problems are either using a broken cord or have a slower USB connection that won’t provide enough power to the Clip?

Anyway, one of the Clips was completely dead battery wise the other was fully charged and once connected properly both worked exactly the same.  I am now full upgraded and loaded.