Sansa Clip power failure!!


I had my Sansa for a month and the battery was good. I have not been recharging excessively but for some reason, today the Sansa just died out of the blue while I was listening to it.

I can’t get it to turn on for nothing. Even when I plug it up into the USB port, it still won’t turn on, and Windows doesn’t even recognize the device.

What is wrong?

Infant Mortality, as it’s called in Quality circles. Some critical component in the Clip has failed very early in it’s lifetime, due to static discharge, thermal stresses, microscopic silicon flaws, etc.

Since it won’t do anything, even on USB power, I doubt it is the battery that has failed. Probably the SoC since 90+% of the “parts” are in that one chip (including all the power management stuff)

Return it, and get another one,  it’s kissed

Try holding the power switch in the “on” position for 10 seconds, release the switch, then try powering up one more time (brief push up) as usual.  Did your clip come back from the dead?

Then plug in to your USB port to charge it up.

Hope this helps!  I had my clip do the same thing once; after a few puzzled moments, I reasoned that the unit got stuck in limbo.  Let us know how it goes!

Bob (earbuds back on) :smiley:

Dude, this thing is TOAST. It won’t turn on for nothing. I tried the power up thing you mentioned numerous times and didn’t do nothing to help it. Thing that sux is that the 30 day return period from Best Buy just ended the first of this month, so I’m screwed.

You aren’t without a remedy: your Clip has a 1-year warranty. Contact SanDisk.

Dude, you aren’t without a remedy: your Clip has a 1-year warranty. Contact SanDisk to exchange it…

So when I call them, just tell them the problem, and that’s it? They’ll just send another one just like that? Also, how long would I have to wait in order to get it?

It all depends on the company.  You should have the player and packaging at hand when you call (and the number to call is listed on the warranty pamphlet that came with your player). You explain what happened and the rep. may have you try some things to see if the issue can be solved; the rep. also may ask you some questions as to use (to see if you did something to harm the player that the warranty doesn’t cover–such as dropping it in the toilet).  If the company agrees that there is coverage, you likely will be asked to mail the item back (typically, insure it and mail it with delivery confirmation);you likely will be given a return authorization no. to write on the package.  And you may have to provide a copy of your original receipt (although that may not be the case here, where the product is only a few months old).  Once the item is received, a replacement is sent out to the address you provided, if the company agrees that this was a manufacturing defect/something covered by warranty.

It takes some time for the mailings, but it’s much better than having lost your purchase price and the item!

Easy repair process: contact SanDisk via their website, and open an RMA ticket.

Just click on the SanDisk logo in the upper left corner of this page. 

Just navigate your way by starting with the support button at the top of the resulting red banner.

I have been amazed at the quality of support and service from SanDisk.
That’s why I plan to buy more cool stuff.  :smileyvery-happy:

Good luck with your new Clip!


Good to know about the web route–thanks!


You know that junk decided to start back working today…a freakin day later I tell you. I was just sitting here at the PC and decided to try the Sansa again to see if it works, and sure enough it turned on. For some reason though, the battery indicator is real low and it wasn’t like that yesterday when it went out. It was at about 50%. STRANGE considering the fact that the thing wasn’t even functioning at all for a full 24 hrs.

I don’t know what the cause of that problem was, but I do know that I don’t trust it anymore cuz it might go out again. I don’t know if it went in some kind of suspend mode or what, or if it just got hot and shut off or something. I don’t know. I used it for about 4 hrs straight yesterday but that shouldn’t be a cause of it just malfunctioning like that, because I have done it before without any problems.

I had already contacted Sansa via website earlier this morning and everything , but I don’t regret it, because as I previously stated, the Clip might go out again and I may still have to end up sending it back.


Just Updated: Sansa customer support contacted me right after I posted this message. The Clip already started working before they replied, so I didn’t get a chance to try out the restoration technique they suggested, so just in case someone else has this same problem that I did, I am going to post EXACTLY what they sent to me. Hope this helps anyone here who has this problem in the future… It is as followed…

_"Hello (Not revealing my name on this forum, sorry),

Thanks for contacting SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

Let me assist you with your concern.

Let us try to force MSC (Mass Storage Class) the Sansa. To do so, please disconnect the player, turn it off and place the player on hold, it should show the orange portion. The Hold switch is the power switch as well, just move the switch to the right to place the player on hold. With the player on hold, press and hold the center, circular button, while connecting the player to the computer, this will put the player into an MSC mode.

Please inform us the results.

Please also inform us the operating system of your computer (e.g., Windows XP, Vista Home Basic, Vista Ultimate, MAC OS X, etc.), as well as the platform (e.g., desktop pc, laptop, camera, mobile phone), the brand and the model of the platform where the product is used.

Should you have further concerns, please do not hesitate to reply to this message or send another inquiry at_

Message Edited by RickD on 01-27-2008 10:47 AM

I would just watch the player over the next few weeks.  Electronics, and people operating them, just can do the dangedest things at times.

Yea, I will watch it.

It’s been 2 days so far and no problem watsoever. The only thing is that I f*cked up the other day and unplugged the clip from the PC because I was about to go out, not remembering that there were a few files transferring to it. I didn’t notice it because it was in a screen behind the one that I was looking at, but when I realized it, I plugged it back in real fast so that the transfer would continue.

While it didn’t damage the player, the Data folder that is on the clip (When you go to explorer and browse the clip) got deleted and a few of the names of the songs will display in Japanese language on the Clip now. I can’t believe I corrupted the d@mned thing but it isn’t all that bad as to affect the funtionability of it though. In order for me to get the dad blamned thing to work, I have to put it into MSC mode, because MTP mode won’t work correctly now.

Message Edited by RickD on 01-30-2008 11:26 AM

neutron_bob wrote:
Try holding the power switch in the “on” position for 10 seconds, release the switch, then try powering up one more time (brief push up) as usual.  Did your clip come back from the dead?

Then plug in to your USB port to charge it up.

Hope this helps!  I had my clip do the same thing once; after a few puzzled moments, I reasoned that the unit got stuck in limbo.  Let us know how it goes!

Bob (earbuds back on) :smiley:

Had a similar thing happen to me yesterday.  It was right after recharging my Clip … it wouldn’t turn on until I plugged it into my USB port.  Not really a big deal but had me nervous there for a minute … but then, I did find myself contemplating one of the new 4GB models … :wink:

    Mine failed out of the blue also while listening to it…I suspected keys in my pocket got into the plug port.  But your message about holding the power button for at least 10 seconds worked!!! Thanks for the help.  I’ve become attached to this great device.  Good to know it is well supported.


Thanks so much for your help! My Sansa failed today and I thought all hope was lost and I’d never be able to work out again.  Thank you SOOOO much for your tip! You’re amazing!

My 1GB clip went dead while recharging.  I was playing with it while recharging, which might be no no.

It wouldn’t come alive even though I try connecting to USB port, powering up down switch, etc

However Neutron bob’s recommendation for holding up power switch for 10 seconds and powering up briefly worked.

the unit came back to life!  

there must be something about 10 second thing. but it saved the clip.


Thank you so much for the information!!I have the 4GB clip and have only used it sparingly for three weeks and it just quit in the middle of a song. It was deader than a doornail. I tried to put it on the charger and it just stayed black. Then I plugged into the computer and still no life. I was ready to take it back to Target and try to get another one but I don’t have the receipt, just the box. (birthday present). I tried just finding out if anyone else had had this problem and you guys hit it on the head. I held the power button for ten seconds and then pushed it on and it came back to life. thank

Add me to the list of saved by Neutron Bob’s tip.  Had a crazy morning with the Clip after inadvertently draining the battery and fully charging it.  For the first time ever it would find and load but wouldn’t  play any music files - just sit there looking like it should play.  Used the onboard “format” intending to reload all the music, but then it went doorknob dead, lights out.  This revived it.  I have now updated the firmware and maybe that will prevent future repeats.