Sansa clip wont turn on unless conected from usb. please help.

I was having some problems with my clip this morning. I went to turn it on and listen to some music and every time i tried to listen to a song it would turn off without saying goodbye or anything just would die.
When i got home and plugged it in the usb charger it turned on and was charging. I checked the battery and it said it was 58% full. Before i left home i made sure it was near 100% so i know for a fact the battery couldn’t have dropped that much without even touching it. I reformatted the player and tried turning it on and now it wont even turn on at all unless it plugged into the usb plug.
I’m using windows XP sp2
also the player only turns on in msc mode. Any help would be great.

i also wanted to note that i have the latest firmware and when i unpluge it fromt the usb cord it just goes blank.

Perhaps try:

–  Resetting the player (on switch held up for 15-60 seconds)

–  Reapply the latest firmware upgrade again (available with instructions in the sticky thread at the top of this forum).

Good luck–

I tried resetting it by holding the on switch for over 30 seconds and nothin happened. I also was goin to try reaply the firmware but when i hold the middle button down nothin happens. Sometimes the sansa logo apears but for a quick second and then it just dies to a blank screen again. I have had the clip for about 4 months now and I beleave there is a 1 year warenty on the clip so i’ll just have to call sandisk up tomarrow and file for  a RMA.

I too have this problem. It was working fine for the whole day on my way to California, but the next day I listened to it for a while and it had half the battery life. I then turned it off, and in the night I tried to turn it on, but nothing. I connected it on m cousins computer, which has Vista and my laptop has XP2, I cconnected it on his, and it charged which made me happy, but once I unplugged it BAM!, it completly shuts off and I cant even turn it on. I plugged it back in and it said that the clock was wrong and that it needed to use the internet to fix it,but my cousin does not have internet. And NOW that I am back home I sync it with windows media player and it does not ask me if i would like to use the internet to fix the clock.

w/e I need help. I tried the latest firmware and nothing. If possible i would like not ro return it.

EDIT: Also, I have tried the “hold” with center button method but it still wont turn on. When I unplug it, It wont refresh like it does when you unplug it. 

Message Edited by hitkid on 03-24-2008 04:46 PM

I’m having the same problem (more or less).

I just put some music on my player,

and now, when I try to turn it on,

he got stuck on the opening screen (SanDisk).

My computer won’t recongnice him ether.

I called sandisk up and got an RMA. I sent it out yesterday and should be getting a new clip in about 3-5 days. Luckly i have a cheap mp3 player for ocasions just like this. With my player not even turning on anymore and i did everything i could i just gave up and called them. Sandisks customer service for the most part is good. I have talked to them on a few occasions and they have allways treated me well.

well that sounds very reassuring, jsc315. I sent them an e-mail a day ago. Hopefully they will responds soon, I do not have another Mp3 Player to listen to.