My Sansa Clip won't turn on?

So my Sansa Clip just turned off on its own today when I was listening to music. It connects to my computer and it has full power in the battery but when I try to turn it on after I disconnect it from the computer, it won’t turn on. It turns off automatically once I unplug it from the USB port.


Thank you!

(I’ve had it for about 2 years now) 

Did you try a system reset (hold the on switch uppermost for 15-30 seconds)?

I’m hoping a lead to the battery did not become undone (which could explain the shut-off when disconnected from the computer).

I am experiencing the same issue. I have attempted a reset. I can access the device via windows. I have attempted a firmware upgrade but without the power on following the update, I am afraid that will not take. I find it quite paculiar that the device will not power up or allow me access to the menu system while connected, yet allows me to sync and seem fine while connected. It is very dead when not connected. I have tried about everything listed on every post I can find with the exception of a reformat. I am willing to try even this should the probability of success be greater than 40%.

Will your player start at all when not connected to your computer?  If not, a battery lead could have become detached from your player’s battery. 

Also, when connected to your computer by a regular power/data USB cable, your Clip cannot be played or generally used (including to get to your Settings); instead, you need to access the files on your Clip through your computer.  That is normal.  You can avoid that by using a power-only USB cable or by only inserting your USB cable into the computer lightly so that the USB cable’s longer data pins do not connect up (or some people will cover them up), or by charging from a wall socket using an AC/USB converter.

My player will not start at all when disconnected from the PC. I can access the files via the computer. How can I check the battery lead connection?

I’m guessing that a lead to the battery came undone.  It can be soldered back (or glued in place using conductive epoxy).  But, you’ll need to try to carefully pry the 2 halves of the case apart.  There are various posts here on that (try a search on the word “pry” ) – seems to work best with a sharp piece of plastic and prying apart starting at the on/off switch.

If the Clip is less than a year old (2 years in the EU), your warranty covers this–telephone SanDisk in that case.  (Also, note that some credit cards will double the warranty period, as an extra benefit–easy to overlook!)

Message Edited by Miikerman on 04-06-2010 10:34 AM

  Thanks Miikerman, I contacted Tech support. I am waiting for RMA approval. It appears the battery lead separation a common occurrence from some of the posts. If this is what has happened in my case, I find it interesting that it stopped playing abruptly while being connected to my wave radio without being touched. I would have assumed something different had it been clipped to my person.   

Message Edited by Plato on 04-06-2010 10:46 AM

Great to hear that you’ll be getting an RMA–much nicer to have a shiny new Clip, than having to pry it open (and likely marring it in the process).

Good show!

I have the same problem that is described here. However, it’s NOT the charge cable that is the problem. I’ve checked it, charged it a couple of times, it still won’t turn on. I’ve tried to reset it, I’ve tried the reset with the forced MSC settings. Still won’t work. Any suggestions?

To clarify things for you, if your Clip powers up when plugged in to the USB port, and then suddenly goes dead when unplugged from the port, this means that the internal battery is not supplying power to the device.

Verify this by tapping the center button after unplugging.  The display should light up.  If not, the battery is either malfunctioning, or an internal wire has come loose as described.  This condition is covered under the warranty.

I wouldn’t attempt opening the Clip if the device is still covered by the warranty; if the warranty period has expired, then repairing the lead is an option.

Bob  :smileyvery-happy:

My brand new blue clip also won’t turn on.  It was almost fully charged when I went on my walk then turned off saying battery low. (I was just thinking how long each chare lasts!)  Since then I’ve tried all the suggestions:  hold pause & center button.  Hold on switch for 30 + seconds, tried different cable.  Even bought a car charger and it still won’t turn on.  I love this player and it’s only 2 weeks old.

I’d leave iit charging for a good, long while, and see if it comes back to life.

Nicely, it’s so new, you could swap it for a new one at the retailer’s, or contact SanDisk for an RMA replacement, if need be.   In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:   

I’d leave it charging for a good, long while, and see if it comes back to life.

Nicely, it’s so new, you could swap it for a new one at the retailer’s, or contact SanDisk for an RMA replacement, if need be.   In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:   

Thank you for your prompt reply.  Somehow it just started working again.  I had it plugged in overnight, but between pushing various buttons, and just leaving it hooked up to the computer, it turned on.  I’m so Happpy

It seems that it does that–the miracle cure.   :wink: