My sansa clip won't turn-on

My sansa clip won’t turn-on,

the battery is fully recharged and I have it for about a month.

I turned-off my computer and connected the Usb cable(it’s the only to get the player to turn on)

I get the following messege:

Refreshing database.

In the case I still can’t reach the user interface.

Any suggestions?

This is resolved here.

The new firmware, which should be released within January, will fix this.

From what I understand the problem is with the format of some of the files,
so I tried to delete all of my music from the sansa clip(manually),
but evry time I restart my computer the music files are still on the clip.
How do I use the softwere listed in the thread you listed in your messege and where do I get it from?
The clip still won’t turn on(at all,as if the battery is dead),
is this related?

Try holding the Clip’s power button in the UP position for >15 seconds, this will reset the Clip, and may help…

I did what you said,
I don’t think affected the situation.(In my opinion the click didn’t restart)

There is no reason to turn off your computer, or maybe I misunderstood. I’m not totally clear on what you are observing. Some questions:

Are you using a Mac or Windows PC? If using a Mac, you must empty the trash after deleting files.

When you plug the Clip into USB, does it come on?

Does is display anything? “connected” or “refreshing database”?

What happens if you pull the USB cable OUT of the Clip when it is displaying “something”?

I use windows XP,
When I connect the usb-I get “connected”
When I plug out the usb cable the clip turns-off and displays nothing.

I understand now why you turn off the PC, this is so the USB port has +5V standby power on it (but no communication with the Clip).

It seems that something is corrupted on the Clip, preventing it from turning ON normally. Or, the battery is totally dead for some reason.

Can you ADD files to the Clip when it is connected? If so, try downloading the firmware file from here and copying it to the root folder on the Clip, then delete all the other files from the root folder on the Clip; as one of them may be corrupted (they’ll be rebuilt if/when the Clip restarts)…

Refresh the Windows Explorer window (hit F5) and see if the files are really added / deleted…if not, stop and report back. If so…

THEN try disconnecting it and see what happens.

If nothing happens, try copying the firmware file again(it should still be there though, and the other files should still be gone), but this time power your PC down and see what happens if you keep the USB connected and do the >15 second reset. HOPEFULLY it will re-flash the firmware, and come back alive and well.

I can add/delete (verified with F5).
I deleted evrything on the clip
then copied the firmware
then I disconnected the clip and tried holding the power button up for 15 seconds.
When I reconnected the clip It had evrything back on it(including songs).
It didn’t seem to help

If you “erase” all the files that YOU put there, and they are not actually removed after a power cycle, something may be very wrong with the flash memory itself or the memory controller section of the SOC.

Do you know what firmware version you had on the Clip, and were you using it in MSC (UMC) mode or MTP mode?

If you were using it in MTP mode or Auto (or had never updated the firmware to 018), have you tried the “forced MSC mode” connection method to delete the files?

I have the latest firmware version

And are you using it in MTP mode (with WMP) or MSC mode (copy & paste / drag-n-drop through Explorer)??? This is a Settings menu option in FW 0.18 (as well As “Auto”)

If you are using MTP mode, please try getting connected in MSC mode by doing the following:

0.) Power OFF the device (not necessary in your case)
1.) Slide the hold/power switch to hold (down)
2.) Press the center button and hold it
3.) Plug the USB cable in
4.) Continue to hold down the center button until the PC recognizes the device

Do it in that order and exactly as specified.

Even if you ARE using MSC mode, try connecting the Clip in that manner anyway.

You may also try formatting the device from Windows, if you haven’t already.

I used wmp to move files.
I did what you told me and I have a new drive (drive name is SANSA M350)
It have some files and folders:
All folders are empty.

What should I do now?

How can I format the clip from windows?(I have the latest firmware on my computer)

Message Edited by BelgiA on 01-18-2008 05:43 PM

Those files look normal. But something could be whacked in the MTP area, which is not visible from MSC mode.

Right-click the drive letter in Exploder and pick Format. Accept the defaults. It should only take a few seconds. Refresh when viewing the drive to be sure the files and folders are indeed wiped.

Then power it down and see. You may have to do this again, and drop the FW file in the root the next time. Definitely check (using the funny key sequence again) that the files were indeed wiped off. Note that if it DOES come back, it will automatically rebuild all the files & folders, this is OK.

If it comes back, go into the Clip and format it again using the Settings menu. Then start over with your music (you should be able to just resync?? I don’t use WMP myself).

(fingers crossed)

Iv’e managed to format clip.
The only problem remains that I still can’t turn on the clip without powering off my computer and connecting the usb cable to the clip.

I’m out of ideas, it could be a bad battery, or ???

Anyone else have any ideas? This is not the only instance of this type problem that I’ve heard of…

Your posts are very interesting.  I have been reading them carefully because I am having the EXACT same problem with my Clip!!

It doesn’t turn on no matter what buttons I push or hold.  I’ve been in contact with Sandisk support for the past few days and we cannot get the problem resolved.  I feel there is a fault in these units with the flash memorys.  SanDisk should RECALL all these units.  I’ve had mine for 2 months that’s it.  We are not the only people having this problem.  There are MANY units out there with this problem.  I’ve researched it!!!  Now they want me to give them the serial number, the product code, and some other info.  They will be contacting me with an RMA#, so I can return the unit to them for a replacement.  Believe me you will need a good microscope to get the serial number on the bottom of the unit.

I guess it’s to be expected considering where these units were made.  It’s ashame, they are very nice players when they work.  They should have made them in the good ol’ USA.  We wouldn’t be having this trouble if they were.

I’m sorry if I offended any one.  But with cheap labor, comes cheap products!!

They should be recalled! 

Based on what Has been described,  it appears there is no battery connection or power to run the device when its unplugged from USB.  It could be a broken wire,  battery connection, etc.  Its not related to the flash memory. 

One thought is perhaps the USB port you are using is a low power one and the battery will not charge?  Verify the battery icon animation when connected to the computer indicates charging or not.  If not try using a port at the back of the computer and let the device stay connected to the computer for 3 hours to see if the charging completes.  If you dont see charging or if when you unplug it immediately shuts off,  its a sure sign that there is no battery power.

Yes, in my case the battery icon shows the battery icon scrolling.  Therefore I assume it’s charging.  After a few minutes the icon then stays soild (no scrolling).  Charging the battery has not been a problem the last two months.  Everything has been good up until I turned off the unit and them tried to turn it back on a bit later.  It’s been dead ever since. 

You are correct in saying the battery is dissconnected internally somehow or maybe even shorted out.  I said the same thing to the Sandisk support but they still had me try upgrading the FW which I did.  The instant the Clip is removed from the USB cable it goes dead!!!  There is definately a power (battery) problem.

Do you know how, or if it’s even possible, to open the case to check it out?  No screws that I can see!!!  Maybe that’s why they just want to replace it for me.  They probably know it’s not repairable.  If I could open it, I could repair it.  But if I would do that, there’s no way I could return it for replacement.  I think I’ll just go that route and get it over with.

But thanks for everyone’s input.  I HAS been very helpfull!!!  I hope the other person in these posts that’s having this same problem get theirs fixed or replaced also.  Good Luck with it!!!  

^^^ Do you know how, or if it’s even possible, to open the case to check it out?

There is no way to replace the battery on a clip.

Message Edited by Tweet on 02-28-2008 02:26 PM