My sansa clip won't turn-on

my sansa clip won’t turn on either!  it has been working fine (had it about 1 month), and today when i disconnected it from the computer… it just won’t turn back on!  help!!!  i tried holding the power button “up,” but it doesn’t help.  also, it won’t connect to the computer.

Slide the power switch Up to the “on” position and hold it there for 10-15 seconds.  Then release, and try powering up as usual.

Bob  :wink:

I found this thread while researching my problem with my Sansa Clip.  I’m having exactly this same problem.  I’ve had my Clip for probably almost a year, with no problems.  Then yesterday, when disconnecting my Clip from my computer, instead of giving me a screen that says “refreshing database”, it just went dead.  I have been unable to turn it on using the left switch as usual, though I am able to use it as normal when it is plugged into my computer (the files are all still there, etc).  However, as I said, once it is disconnected from my computer, it is effectively dead.  Anybody come up with a diagnosis for this?  Has it been determined that this is a power/battery issue?  What can I do?  I miss my Sansa Clip very much and want to know if I should go out and get a replacement MP3 player or what, though now I’m reluctant to get another Sansa product.  Any info would be appreciated! 

It sounds like one of the leads to the battery may have become detached.  I would telephone SanDisk for a warranty replacement (before your 1-yr. warranty is up …).

I seem to be having some of the same problems listed in this thread, except when I disconnect the Clip from the computer (after updating the Firmware, manually I might add) it will sometimes say “updating firmware.” It will do something for about ten seconds then power on, work great, then die again and remain dead until I repeat the aforementioned steps to fix it about nine times. I made sure to try it before charging it and after charging it for three hours to make sure it might not be a battery problem, but I can’t really tell. SanDisk support hasn’t been any help because some lady told me there weren’t any battery problems with the products as far as she knew. It works fine when plugged in, but disconnect it and it’s dead to the world. Any suggestions?

Hi,

Did you try resetting it by holding the “on/off” up for 15 seconds?  That’s what I have to do most of the time and I’m so relieved when the lights come on!

Thank you so much for your advice, it seems to be working for me!  You are very patient!

Yeah, I tried resetting and it does nothing at all. It does absolutely nothing. I’m pissed off about this battery thing, which I found out is one of the major problems with the products. Can somebody fix this?

Yep, SanDisk with a warranty replacement.  I’d telephone them again and tell them that’s what you want/need.  If the battery lead has become disconnected, the only way to repair it is to disassemble the unit and re-solder the lead–not for any casual user to do (and it would likely void your warranty).

yes it’s true about the battery. No matter what i did, no matter what mode i was in, as soon as i was unplugged from the  usb to my puter i was dead in the water and the clip won’t turn on. so as a last resort i opened the clip. it clips together and isn’t glued so you just have to be careful in how you pry the clip apart and keep track of how the slide on-off and volume pieces go. be careful how you pry cause you mangle the soft plastic as you go. what i found were 3 very little wires come off the battery, red, blue and green i think, and are soldered to the printed circuit board. my red wire had broken away from it’s solder joint, hence no connection. if you’re good with in-close spaces, you can trim back this wire and epoxy it back to it’s place on the board. i held my battery in position with a wad of tp underneath it and a rubber band. then when i put the wire where it should go the interface lit up. while it’s lit (meaning the connection’s made) i dabbed a drop of epoxy onto the connection. i suppose you could solder this connection, but you’d need a very small soldering iron and like i said it’s in a very small space. anyway, i had to try something or else just toss the clip as i tossed the receipt for it already. hopefully this connection lasts for me but, so far so good. good luck.

I have this same problem, but I can actually get mine to turn on (I have to smack it actaully), but once it does it says “Refreshing Database” for about a split second, the bar moves up and then it shuts off. My brother had the 2G (I have the 4) a year or two ago and his did this exact same thing within a month of having it, and sure enough, it’s been nearly 2 weeks with this thing and it’s already having this problem. My only conclusion is that these things are deffective, but I could be wrong and it could be a common error we both made.

I have resolved this entire thing by taking apart my own sansa.  There is a red wire that seems to be defective in all sansa clips.  I used an electrical iron and put it back together.  I had two problems actually.  I was in MTP mode and the wire was not attached.  It would charge when connected but without the positive connection it wouldn’t turn on.  So I got it working, not I need to do recovery mode or something to fix it.  I’m currently making a youtube video on how to fix this problem if anyone wants to check it out.  It should work if you want to venture opening it up.  I even let you know where is the best place to open it up with and with what.  So I hope this resolves it for a lot of people.  I know I was pissed for a while.

Cheers!

Davia (drumsexy9 at youtube  should be up around jan 14th or 15th 2009)

Thanks for sharing your efforts!

Dang, I’m a dead man.  My wife let me use her Clip (I have a fuze) and when I was coming back from the Gym I tried to turn on the clip and it wouldn’t turn on. It has been charging for over 5 hours and still doesn’t show a full charge and immediatly after disconecting the clip from a wall charger it goes dead and wont turn on.  My wife is not going to be happy :(.

I got an RMA, I send in my clip, they will take 7-10 days to ‘process’ my clip and they will eventually send one back.

hey my red wire is disconnected.  What is the best way to strip the wire (it looks so thin), and what is the best way to attach it back to the connection.  Is epoxy cheap? and where could i get some?  (home depot?)

Epoxy!

I think not.  Resin is non-conductive.  The wire needs to be soldered carefully.  If you don’t have the proper tools or experience, see if a friend has some electronics experience.  Then you’ll have a proper repair.

Bob  :smileyvery-happy:

no bud, they do sell conductive epoxy used in place of solder.

i’ve respectivly read all 4 pages as well as other solutions, my screen still goes shot dead after i unplug it

(hold center for 15 seconds while on hold)

(nothing can be added or deleted)

so on and so forth

Likely, then, that the lead to the battery has become disconnected?  If you have warranty left, contact SanDisk?