Sansa Clip- not turning on

My sansa clip was working fine about a week ago, but then it turned off all by itself. I tryed various methods to turn it on, but all to no avail. I then tried connecting it to my computer, and it was recognized and said that the battery was 98% full, so I decided to wait a few days before trying to turn it on again. Can you help me fix this problem? I think it may have started with a corrupted mp3 file, because after I tried listening to it, it turned off automatically. Please help, and thank you!

Message Edited by watersnow11 on 02-15-2009 07:10 PM

Wow! I don’t know what I did, but it started being recognized by laptop again; though it still won’t turn on when it is not connected. Can you please help me fix it?

The same thing happened to me today. I just added a new song and it started working ok again. Try it who knows.

John

If your trusty Clip freezes up, you can perform a soft reset by holding the power switch in the ON position for 10-15 seconds.  Release the switch, and restart the player.

Most often, the cause is a simple glitch in the file being played.  If the problem recurs, you can connect (in MSC mode) and use the chkdsk utility in Windows.  Chkdsk was handy years ago with those genuine floppy disks- I mean the 5 1/2 and 8-inch variety.  Who knew it would come in handy over 20 years later?

Bob  :smileyvery-happy:

Thank you for the help, but I’ve tried resetting it that way many times, but it still doesn’t work. I’ve never tried the chkdsk program though, but it doesn’t seem to work.

By “it still doesn’t work”, do you mean that the player still hangs up, or that it will not power up, or it will not be recognized by the computer when plugged in?

Starting with the Clip OFF, slide the power switch to the HOLD position (orange showing).

Open a Windows Explorer window on your PC via [Windows key] + E, or via My Computer.

Press and hold the center button while connecting the Clip.  In a few seconds, the player should connect in MSC mode.

The clip will show up with an assigned drive letter, like E: SANSA CLIP, listed under “devices with removable storage”.

Make note of the assigned drive letter.

Now for chkdsk :

In the Run box, type cmd [enter].  An MS-DOS command session will open.  Type, using the assigned drive letter of the Clip:  chksdk e: /f  [enter].  The /f is a toggle, telling the application to fix errors found.  If it asks if you’d like to save the data as files, say NO.

This should return your Clip to normal operation.  At the very least, it will now be accessible to format and reload the device if you wish.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 02-16-2009 10:00 PM

Strangely, it seems to be doing either 3 at different times. First it doesn’t turn on, but when I connect it to my computer it only ‘sometimes’ gets recognized by my computer, and while it’s connected to my computer, it seems to start charging, but then, the screen freezes. Because of this, I still haven’t been able to do the command prompt on my sansa disk. But my sansa clip has usually started being recognized by my computer after a period of time away from it… whether 5 minutes or half an hour. Whether it works or not, thank you for your hel! I’ll try doing that, and I’ll tell you how it works out!

Message Edited by watersnow11 on 02-17-2009 07:20 AM

I’m having the same problem-

I have a Sansa Clip 4GB that was working perfectly fine yesterday, but it suddenly turned off last night while I was using it, even though it was 100% charged (I checked). I have tried soft reseting, connecting in MSC mod, but when I connect the Clip, a bubble pops up in the lower right hand corner of my screen that says that my device has a malfunction or something.

What else can I try?

Ditto on the problem with the Clip not turning on.  I have followed instructions and have reformatted the internal memory of the clip.  I have copied the bin file to the directory.  I can connect with it, I can sync music with it (I verified the files were there)… but I cannot get it to turn on.  The only time the screen will light up is when I connect it to the USB port on the computer.

I am having the same problem.  Sounds like its a manufactured issue.  My clip will not turn on at all after shutting off on its own during a workout.  I got home and tried to let it charge overnight but still nothing.  Now it wont even show up on any computer I plug it into.  Too bad, it was a Christmas present that I only got to use for a month.

If the Clip freezes during playback, and turns off, the soft reset will bring it back to life.

Slide the power switch to the “on” position, holding it there for 15 seconds.  Release, then try powering up normally.

Bob  :smileyvery-happy:

I just had this happen to me this morning, with my 1GB Sansa Clip. It was working normally yesterday, I tried to turn it on this morning, and nothing. It still works normally when connected to the computer, but only as long as it is connected to the computer.

 

My conclusion: dead battery.

 

At first I thought another possibility might have been a broken switch. But I added a file and then disconnected it from the computer. Instead of saying “Updating database” as it normally does when something has been added, it just goes black as soon as it is disconnected.

 

The obvious thing that would cause this exact situation to happen would be a dead battery.

 

I’ve had it for 1 year (since Feb. 2008). I would think a battery - especially an unreplaceable battery - should last more than 1 year before it completely dies.

 

I guess there’s nothing to do now but get a new one (at least they’re not terribly expensive) and hope the next one has a better battery.

 

 

It likely isn’t the battery, but one of the leads to the battery became undone.  The warranty is 1 full year–are you still covered?  I’d contact SanDisk quick.

If you’re more adventurous and if the warranty is expired, you could take the player apart (carefully) and re-attach the wire (either by soldering or using conductive epoxy).  There have been posts here as to this.

Good luck!