Unable to transfer photos

Trying to backup my photos. Clicking on “all” most “fail” and won’t upload.

When scrolling through manually most will load and disappear before I can click on it. Can only save a few. 

Other issue - tried to auto-backup camera roll. Get an “error: iOS Background Transfer Fail”

 So frustrated not to be able to find these troubleshooting problems on the website or manual 

how much free storage space is on your iOS device? Basically the way iOS works is file transfers are copied to the clipboard then the transfer is made and the clip board is cleared. If you are low on internal storage transfer may fail. try transferring in smaller chunks until you can free up some more space on the iOS device. 

If you have plenty of free space what happens if you transfer smaller amounts? Do you see the same transfer failures?

Hello, I just bought the sandisk wireless connect 64 GB for my iphone and upgraded the firmware. however I am unable to upload a single photo from my phone to the memory stick. I get confirmation that the tranfer is in progress but its endless. I do have around 1.2 GB of free space so the copying to clipboard should not be a problem fro a single photo which is just 2 MB… Can you suggest what else needs to be done to fix this or do I need to make any changes to my app or phone ?

I keep trying to import my photos from the connect drive to my iphone but this keeps appearing. It’s becoming really annoying I can’t get the pictures I need on my phone. What to do with this? Need immediate response. 


When I try to post a picture, the app locks except for the ‘wheel of death’ (wait).  Having read various other messages I have changed to a static IP address but this has not solved the problem.  Any ideas?    

And I have plenty of space on my iphone…