Problems transferring photos to wireless stick


I was hoping someone could help. I purchased the wireless stick a few days ago to try and help clear some space on my iPhone 6. I managed to download the app fine and connect through wifi etc. But whenever I try to transfer pictures from my phone to the wireless stick nothing happens. It says at the top ‘transferring 11 files’ and I’ve left it for hours and nothing happens. I tried doing it with just one file and still nothing happens. 

Does anyone know what is going on? Or am I missing something?

My phone and the app is all up to date too. 


I am having a similar problem with my 32gb version.

Iphone 6, running the latest update and the latest firmware of the stick. 

When I start to transfer files, if I tap on “hide”, or use the home or lock button to go out of the app, the transfer seems to freeze. Sometimes it continues in the background and I can find the files that I wanted to transfer in the folder that I selected (all basic pictures btw. nothing fancy, tried to eliminate possible causes). However according to the app, the data is then still being transferred. 

I tried also several changes with the network settings etc. but nothing seems to help. I am guessing this is an issue with the new iOS. 

Help would be much appreciated, 

If the issue is only occurring when the app is in the background it could be due to iOS. When apps are in the background iOS controls the resources provided to the app so transfers may hang or pause. Do you see the same issue if you keep the connect drive app in the foreground while a transfer is occurring?

Yes, my problem still happens in both situations. Even when I leave the app up and running on my screen still nothing happens…

If it is to do with the IOS what would you suggest to resolve this? Would I have to wait until there is another update?

If you have not tried it already start by force quitting the app and relaunching. If you still see the same issue uninstall and reinstall the app. If the issue persists after that power cycle the phone. 

If all that still fails I would try formatting the drive. Connect it to a computer and if you have 32GB or less use FAT32 file system. if you have a 64 or higher use exFAT. if you are formatting on a mac make sure and use master boot record for the partition scheme. 

If you still see the same issue I would suggest contacting sandisk support and submitting the debug logs so they can review. IN settings go to about and scroll to the bottom. Choose start capturing logs. Then try the transfer again. Let it set for a few mins. Then go back to settings about and choose send logs. You can send them to yourself. Once you have the logs open a support request with sandisk support and submit the logs. 

I, too, am having the same problems. This is a brand new, out of the package stick. I can backup my contacts, transfer music from PC to Stick, but not backup photos or videos to the stick.

I tried all these items to no avail.

I have exactly the same problem. New 64GB stick purchased 18 Feb 17. Will transfer photos  OK stick to IPAD.  Trying to transfer a single photo from IPAD IOS10 just shows continuous  “transferring 1 file”.Then times out after about 1 hour.




Can new pics from my phone be automically transferred to my wireless stick?

Can pics be transferred to the wireless stick when my phone storage space is full?

Can anyone help?

Pat Ong

if you have auto backup turned on when you launch the connect drive app new pictures will be backed up. 

if the phone storage is full pictures can still be transferred. Videos cannot however. This is due to limitations in iOS. 

I am having problem transferring photos from iPhone to sandisk. It could take up me few hours but nothing was transferred at the end. 

Hello everyone, I have found a fix. I was having the same issues as you all. App kept crashing or only one or two files backed up then all of a sudden it stops saying ‘Backup complete”. The fix is instead of connecting to the SanDisk built in wireless network connect to your home wireless network. Once your phone is connected to your wireless network you then need to connect the SanDisk Connect to the same network (Go to the Sandisk menu and at the top where it says internet connection this is where you connect the Sandisk to the same network.) I’m using an iPhone 7 and even now as I’m typing this message the SanDisk Connect is backing up with no issues. Once your files are backed up you can then reconnect to the Sandisk built in wireless network and all your files are now there. Now you can turn on Auto Backup. Goodluck and I hope your issues have been resolved. Remember connect the Sandisk to a good wireless connection not the built in Sandisk wireless connection. Make sure both the phone and Sandisk are on the same stable connection. If you don’t have broadband then try connecting to a Starbucks or a friends house. My files backing up are over 3000 images and it’s already half way. Goodluck