Unable to authorize the device

Hello, I have the Sansa Fuze which I just bought and I am having some technical difficulites with it. Everytime I try to drag a channel onto my new Sansa Fuze it says: “The channel could not be transferred because Rhapsody was unable to authorize the device.” Then, a screen pops up saying “sorry, The page you requested cannot be found. Please press the back arrow.” Note:The device name is not all uppercase.

I have restarted my computer and I have the latest version of Rhapsody. I have also “formatted” my fuze which deletes all information on the Sandisk Fuze. Please help me!! I want some channels.

Note:I also have the latest version of Windows Media Player. 

Message Edited by metalzoa78 on 12-27-2008 06:50 AM

You need to sign in to your Rhapsody account and click on the authorizations link.

thc cammoy but I am signed in but this is still not working.

In the sources pane of the Rhapsody 4 client, you will see your Fuze.

Right-click on the Fuze, and select Authorize.

Click on the Fuze to expand the listing.  Do you see “Channels” and “Playlists” below it?  If you do NOT, let me know, and I’ll walk you through the repair process, if the RhapPFS system is corrupted on your Fuze.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 12-26-2008 05:49 PM

I do see “channels and Photos” etc. But everytime I click authorize it says uanble to authorize and again it gives the same screen.

anyone have any ideas?

On the device: Settings > System Settings > Format > Yes.

Next up, MTP Mode.  Settings > System Settings > USB Mode > MTP.

Open the Rhapsody 4 client.  Click Help > Check For Updates.  The latest two releases include patches specific to the new Fuze.  When updating, DO NOT have the device plugged in.

With the Fuze plugged in, try right clicking on the device and see if the Authorize function works.

Bob  :smileyvery-happy:

When i tried to update it, it says that I have everything i need. I tried to authorize again and it still will not work.

Did you format the device as above?

Bob  :wink:


Bob got any ideas?

Think is should leave it alone? I can download songs i believe. Also get pictures,vid but not Rhapsody channels.

I have the same problem as you metalzoa78.

I have two Sansa Fuze (4GB) two different XP Pro systems and neither PC will reconize the Fuze unless you set the USB setting to MSC.  I’ve been in contact with SanDisk and we manually updated the firmware to 02.01.17. But it still will not be reconized on autodetect.  SanDisk has referred me to Microsoft which caused me to lol on the phone with the SanDisk support person.  I’m investigating any hotfixes that may resolve the MTP problem.

Just to clarify, for your Fuze to be “authorized” the USB setting has to be in MTP or Autodetect mode.   

I’ll post more later.  If someone else knows something please post.  Thanks.  Doug

Thanks-I also sent www.sansa.com/support a message… so far they have’nt contacted me back. They should make another patch or update for this outragous problem.

Okay, let’s go deep.

Check out this thread, detailing repair of the RhapPFS system.  Well, I’ll paste the details here, since it directs to the Sansa Clip firmware.  For the Fuze, the process is the same, since SanDisk has wisely run with the same processor in both devices:

While connected, The CIA had a look at your channels, and determined that they were not for you.

Just kidding.  My favorite PC Poltergeist, Windows Media Player, has taken your playlists from the Rhapsody folder and reinstalled them in the general playlist folder.

I enjoy grappling with my WiMP friend.  To do so properly, you must litter your desk with Fritos and drink Diet Coke until pretty colors start to dance around in your peripheral vision.  In this Altered State, you can mind meld with the Microsoft programming team, and understand the application responsible (and necessary) for the MTP transfer protocol.

How to repair a zorched Rhapsody Channels system:

In this case, the RhapPFS system is messed up, yielding no Rhapsody Channels feature when subscribed.  Note that your regular Rhapsody downloads ( “to go” ) transfers may still be available.

With the device connected, and available in the Rhapsody 4 client, note that the Channels sub-folder is not displaying below your Sansa in the sources pane.

Fear not.  You may lose a bit of hair if you attempt to solve this one via Rhapsody support.  You’ve come to the right place.

Close the Rhapsody Client for now. 

Leave the Sansa connected, since we can do this surgery in either MSC or MTP mode.

Open a Windows Explorer window via [Windows key] + E, or under “My Computer”.  Your Sansa will pop up. If it is in MTP mode, the only difference is that you’ll need to double click on Internal Memory to expose the root directory of the Sansa.

While you’re in here, you can drag and drop any music data to a separate folder on the desktop, and save files, or if there are copies in WiMP’s “My Library”, you have backups for convenience.  Rhapsody tracks can simply be reloaded from the server, or from your PC if you have files set to cache on the PC.

Let’s go deep.  In the list of folders, see the Service Folder?  Delete the Rhapsody folder inside it.  If you’re curious, within the Rhapsody folder, you’ll see the subscriptioninfo folder with your Rhapsody account data, a playlist folder with your genuine Rhapsody Channels nested within it.  The Sansa stores the Channels in here, keeping them hidden from the regular population of music files.

If there’s a folder duplication visible in the root directory, as in two Service folders or Rhapsody folders, delete the empty ones.

Now for an important step.  Did you install the latest firmware using the Sansa Updater, or manually?  I hope it was manually, as you’ll be familiar with the process.

You’ll need to drag and drop another copy of the firmware into the root directory of your Sansa.  From the Sansa Fuze Firmware Thread, you can download a copy of the firmware as a zipped library.  Unzip this file, and you’ll have a firmware binary called fuzea.bin that you simply drop in the root directory.  This is the open Windows Explorer window showing all of those folders- simply place the file in the box, but NOT into any of the folders.

Unplug your [Fuze], and firmware update in progress will display.

After that’s done, open the Rhapsody 4 client again, and sign in.

Installing the firmware prepared the Sansa for a fresh account installation, with a new folder tree generated in the process!

The Clip will appear in the sources pane in the upper left.

Right-click on the Sansa, and select Authorize.  Oh, did you notice that the Rhapsody Channels folder is back, below the Clip listing?  Good stuff, huh?

The Sansa Clip is a RhapPFS compatible device, meaning that it automatically becomes a Rhapsody device when authorized, giving you the Channels feature in the main menu too.

Now, enjoy filling up your restored Clip.  Choose your channels from your Channels list, and drag them over to the folder, or choose ones directly from the Music Guide.

These wee beasties are pretty resilient.

Enjoy your music once again!

Bob :smileyvery-happy:

2 questions. After I see the service folder are you sure I want to delete that?

And I am not a “to go” member yet. I am not subscribed but I cant authorize my FUZE. Sorry lost you after delete service folder. 

Tried it Bob. Still cannot authorize my Fuze.

That was pretty deep.

However, what I’ve done to resolve the problem is listed below.

I did install Microsofts mtp porting kit, I got it from:


However, that didn’t do the trick.  So, I rolled back my installation of Windows Media Player 11, then I downloaded the latest Windows MediaPlayer 11 from here: http://www.microsoft.com/windows/windowsmedia/player/11/default.aspx and installed it.

When all was done I connected my Fuze with the USB setting set to “autodetect”.  Windows picked up the Fuze this time and I was able to authorize it successfully.  I then completed the same process on my son’s XP system and was able to authorize his Fuze.

Good luck, let me know if you have questions.

Message Edited by dfmcse on 12-27-2008 12:09 PM

I downloaded both things but still in Rhapsody It wont let me authorize the device.

On the off chance it’s something too simple to think about…is your subscription paid up for the month?